summaryrefslogtreecommitdiff
path: root/app-shells/rc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/rc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/rc')
-rw-r--r--app-shells/rc/Manifest4
-rw-r--r--app-shells/rc/metadata.xml8
-rw-r--r--app-shells/rc/rc-1.7.4-r1.ebuild44
-rw-r--r--app-shells/rc/rc-1.7.4.ebuild42
4 files changed, 98 insertions, 0 deletions
diff --git a/app-shells/rc/Manifest b/app-shells/rc/Manifest
new file mode 100644
index 000000000000..f560f8c97eff
--- /dev/null
+++ b/app-shells/rc/Manifest
@@ -0,0 +1,4 @@
+DIST rc-1.7.4.tar.gz 215206 BLAKE2B df01f618cd4d3c5bbf155768ada49c20fe7916e2b999ae13d08487b00c4565c3c4d1d45d16dddef70fe58cf7c405d293832b31dc8a66d8b36b2503675b260db1 SHA512 49e124207b5370b88b8fba0376dda33451451a58bfb85fabfc06ae59eb88fedf38d7aeaaf292e4f380e2c00efc8301ba68d12180923186d1c53ef94f78f7e435
+EBUILD rc-1.7.4-r1.ebuild 931 BLAKE2B 68829f9ee2219282bfb380ded88f23dbfea27a78a8d78f7a150172df26deedb28878324bff39ec04b9d87c31d64310f8b32ef5d217903a72dae79ab44b3209eb SHA512 74abce16dd79d884cc7067585b5295b16704edfe1695caaecd6c8389bea8821465533e71f0da2219417ae4b81f9798ed94542483baa12fca57b81b915a699ba0
+EBUILD rc-1.7.4.ebuild 891 BLAKE2B cd4906a048ce647f7bdf36bb6e6bb57075190cca66f14e52e5216fdf8af2661315d7e76850d6e624be390d824c420210e928dbbb2f417b0bce721e8b93a5978c SHA512 510499cf748c113ec3a2ed6338e3a36256da9166ec3a6fcb49f31597e75c078409387ca40a883236c7158e150e01919f3993bc5aef6e052d2a74787b7efa988b
+MISC metadata.xml 263 BLAKE2B da35927a73cc22621ec3170a872817bc1f2e91967dd369f21f6543ce2a02e995eb654ab2c1209bae764ef194788828e00daf5d559d3a26926e6912838075dc7f SHA512 b25a1229f571493fdde40749d60d17d411676854bc3f73810e15edac8a2a930d3633f46a6f7f5a7ec6cf7f36b9ef690a7e03916c7c76869315f5ba1f862fd0f0
diff --git a/app-shells/rc/metadata.xml b/app-shells/rc/metadata.xml
new file mode 100644
index 000000000000..3e60a9a347a4
--- /dev/null
+++ b/app-shells/rc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/rc/rc-1.7.4-r1.ebuild b/app-shells/rc/rc-1.7.4-r1.ebuild
new file mode 100644
index 000000000000..9e73cae38eae
--- /dev/null
+++ b/app-shells/rc/rc-1.7.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://static.tobold.org/"
+SRC_URI="http://static.tobold.org/${PN}/${P}.tar.gz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="readline? ( sys-libs/readline:0 )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-edit=readline"
+ use libedit && myconf="--with-edit=edit"
+
+ econf \
+ --disable-dependency-tracking \
+ "${myconf}"
+}
+
+src_install() {
+ into /usr
+ newbin "${PN}" "${PN}sh"
+ newman "${PN}.1" "${PN}sh.1"
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! grep -q '^/bin/rcsh$' "${EROOT}"/etc/shells ; then
+ ebegin "Updating /etc/shells"
+ echo "/bin/rcsh" >> "${EROOT}"/etc/shells
+ eend $?
+ fi
+}
diff --git a/app-shells/rc/rc-1.7.4.ebuild b/app-shells/rc/rc-1.7.4.ebuild
new file mode 100644
index 000000000000..71bf031e21ab
--- /dev/null
+++ b/app-shells/rc/rc-1.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://static.tobold.org/"
+SRC_URI="http://static.tobold.org/${PN}/${P}.tar.gz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="readline? ( sys-libs/readline:0 )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-edit=readline"
+ use libedit && myconf="--with-edit=edit"
+
+ econf \
+ --disable-dependency-tracking \
+ "${myconf}"
+}
+
+src_install() {
+ into /
+ newbin rc rcsh
+ newman rc.1 rcsh.1
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ if ! grep -q '^/bin/rcsh$' "${EROOT}"/etc/shells ; then
+ ebegin "Updating /etc/shells"
+ echo "/bin/rcsh" >> "${EROOT}"/etc/shells
+ eend $?
+ fi
+}