summaryrefslogtreecommitdiff
path: root/app-shells/smrsh/smrsh-8.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-shells/smrsh/smrsh-8.15.2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-shells/smrsh/smrsh-8.15.2.ebuild')
-rw-r--r--app-shells/smrsh/smrsh-8.15.2.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-shells/smrsh/smrsh-8.15.2.ebuild b/app-shells/smrsh/smrsh-8.15.2.ebuild
index 5679f879ea94..d253f8f3657c 100644
--- a/app-shells/smrsh/smrsh-8.15.2.ebuild
+++ b/app-shells/smrsh/smrsh-8.15.2.ebuild
@@ -1,27 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Sendmail restricted shell, for use with MTAs other than Sendmail"
HOMEPAGE="http://www.sendmail.org/"
SRC_URI="ftp://ftp.fu-berlin.de/unix/mail/sendmail/sendmail.${PV}.tar.gz"
+S="${WORKDIR}/sendmail-${PV}"
LICENSE="Sendmail"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="!mail-mta/sendmail"
DEPEND="${RDEPEND}
- sys-devel/m4
- >=sys-apps/sed-4"
-
-S="${WORKDIR}/sendmail-${PV}"
+ sys-devel/m4"
src_prepare() {
- cd "${S}/${PN}"
+ cd "${S}/${PN}" || die
+
+ default
+
sed -e "s:/usr/libexec:/usr/sbin:g" \
-e "s:/usr/adm/sm.bin:/var/lib/smrsh:g" \
-i README -i smrsh.8 || die "sed failed"
@@ -33,8 +34,8 @@ src_prepare() {
}
src_compile() {
- cd "${S}/${PN}"
- /bin/sh Build
+ cd "${S}/${PN}" || die
+ /bin/sh Build || die
}
src_install() {
@@ -44,10 +45,9 @@ src_install() {
doman "${PN}.8"
dodoc README
- keepdir "/var/lib/${PN}"
+ keepdir /var/lib/${PN}
}
pkg_postinst() {
elog "smrsh is compiled to look for programs in /var/lib/smrsh."
- echo
}