summaryrefslogtreecommitdiff
path: root/app-shells/yash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
commit27b3683509c5229cce540418778a8b64afbc0009 (patch)
treeb7164898142b8b093b91c8254c4387b6eec679ee /app-shells/yash
parentf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (diff)
gentoo auto-resync : 17:02:2025 - 00:13:57
Diffstat (limited to 'app-shells/yash')
-rw-r--r--app-shells/yash/Manifest2
-rw-r--r--app-shells/yash/yash-2.58.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index a56b54fa4fd9..5b46c908e180 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1,3 +1,5 @@
DIST yash-2.57.tar.xz 771228 BLAKE2B ea11d63c013a5b967ff32984e33b2b0113e3101b233d5923e902a15d1f1b53142f4266dd54df85776dd7ad45f4045c5cee500e7de764e92d2e2e87b7e2fbf19a SHA512 6604ce54f698740d99e4ce3e6ff93b10936353b0690871b4dd1a0ef4569fc228284f551398b4912d324c8627eccec4cd51ac58508f741eb47b315560f02bff01
+DIST yash-2.58.1.tar.xz 784816 BLAKE2B e3495d60303571fef6a754df70719cab4ca71b14d198451d9e4111f4306d76450ff73cd2d4ae8ec97d0bde905e6f1e9b37c908150155b21f93f70e6f6685b1e7 SHA512 01e87d579db4ad15ff475cdb7a5360e1b1b6d0e39301e191910943f99adb6686e2462645114c68b59e3de53c5d4486748a9d070a47e3d148e6e3f84b000f1318
EBUILD yash-2.57.ebuild 842 BLAKE2B 7c6ee25b34971087b8c64e6df95f6fc917033c0394f59a956283f711b1fd10547730ebdbda7b473469de04fe680f6f83342dbe70af3e4ecac0119ffec5169283 SHA512 13645cab3a7b5ede7f9aa434c99e2432fbb59e59c1604e9094cbf5789246b7109e8f648e4e73345e11881803a16f275c6ed3ef01b60cd0c9e34faf851cb9ed40
+EBUILD yash-2.58.1.ebuild 844 BLAKE2B d7bd18bc6657df45824fa930c6980ef5641f087c0f7de0c52d35b6c3391e3817bfb8f1211c42a24f27d6866803a2671734a20492f9d935d1dcab31eacc8bff13 SHA512 cd7c1a7a0feae86a32141c691465607a0ed0a2d22ed46743290cead505ced8e0a12e979b0654594e4fb1dab19133c95658ec410b15807dc68408b96eaf32dece
MISC metadata.xml 1065 BLAKE2B ab9ec0ac6fbf2666a7e987b6a4cfd62f8520f541eb0d900602a782f895757d85ab07f61ca60cfab3cd6042a4e24cb311eb17a4fc163c2652f3c9b7ec4f3cafa2 SHA512 1bf5664d53623cc41a2509662889fe967b62068b27d36f30152fb59de29b46af03ea5baa1a778b2dca6232ffe3d564db37a6432f5f8cdc585a8c88e87fc9ab9f
diff --git a/app-shells/yash/yash-2.58.1.ebuild b/app-shells/yash/yash-2.58.1.ebuild
new file mode 100644
index 000000000000..dd0a188a2e22
--- /dev/null
+++ b/app-shells/yash/yash-2.58.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://magicant.github.io/yash/"
+SRC_URI="https://github.com/magicant/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC="$(tc-getCC)" \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}