summaryrefslogtreecommitdiff
path: root/app-shells/yash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-10 11:05:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-10 11:05:14 +0100
commitfbbf0ee3d56a6fd27adf182c6907dc745623aeaa (patch)
tree2c2869a78e5e3b6af9391df951ca217cced4608d /app-shells/yash
parent43297a4ed0a3760bbdd0b8c286b779f174ca5368 (diff)
gentoo auto-resync : 10:08:2024 - 11:05:14
Diffstat (limited to 'app-shells/yash')
-rw-r--r--app-shells/yash/Manifest2
-rw-r--r--app-shells/yash/yash-2.57.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index 14e980fb1a2b..2e05c780bfd9 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1,3 +1,5 @@
DIST yash-2.56.1.tar.xz 768752 BLAKE2B 8ee4c654e85b5895096870afcb3fc4e855274f3fd1956372753a46c522430a59c8ba96e64b0b13672e0289d2a9b6492a18a0f3d9e9e5500f53144ed1d56ca750 SHA512 28e8bde5fc12e5178136b82ecdc0c52c37c98301245089b0d55c43266880e299237a5522e572883e5c51b7d9a0e9bf94fe265a9ebdbf346c28ff837b0f60cc00
+DIST yash-2.57.tar.xz 771228 BLAKE2B ea11d63c013a5b967ff32984e33b2b0113e3101b233d5923e902a15d1f1b53142f4266dd54df85776dd7ad45f4045c5cee500e7de764e92d2e2e87b7e2fbf19a SHA512 6604ce54f698740d99e4ce3e6ff93b10936353b0690871b4dd1a0ef4569fc228284f551398b4912d324c8627eccec4cd51ac58508f741eb47b315560f02bff01
EBUILD yash-2.56.1.ebuild 842 BLAKE2B 7c6ee25b34971087b8c64e6df95f6fc917033c0394f59a956283f711b1fd10547730ebdbda7b473469de04fe680f6f83342dbe70af3e4ecac0119ffec5169283 SHA512 13645cab3a7b5ede7f9aa434c99e2432fbb59e59c1604e9094cbf5789246b7109e8f648e4e73345e11881803a16f275c6ed3ef01b60cd0c9e34faf851cb9ed40
+EBUILD yash-2.57.ebuild 844 BLAKE2B c91811fe1d24dc044ed26c2610015ef35dcb2d0ea11e58c7c0aefc09d4cf7d74336422a8238b6862bfd96f381ece8e5df0e2dd6d8ce3ffc7632a3da759a4cbfb SHA512 1b7ff8db51e0f55a47109671de85e54d341551e855ca749a503f1c0fb2b6b0b2190534c5f5a0caadfa75f57a808b7e4da9b21b8db59280302bf334dfff7322db
MISC metadata.xml 1065 BLAKE2B ab9ec0ac6fbf2666a7e987b6a4cfd62f8520f541eb0d900602a782f895757d85ab07f61ca60cfab3cd6042a4e24cb311eb17a4fc163c2652f3c9b7ec4f3cafa2 SHA512 1bf5664d53623cc41a2509662889fe967b62068b27d36f30152fb59de29b46af03ea5baa1a778b2dca6232ffe3d564db37a6432f5f8cdc585a8c88e87fc9ab9f
diff --git a/app-shells/yash/yash-2.57.ebuild b/app-shells/yash/yash-2.57.ebuild
new file mode 100644
index 000000000000..9084d796b0ba
--- /dev/null
+++ b/app-shells/yash/yash-2.57.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://magicant.github.io/yash/"
+SRC_URI="https://github.com/magicant/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC="$(tc-getCC)" \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}