summaryrefslogtreecommitdiff
path: root/app-shells/zsh-completions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-shells/zsh-completions
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-shells/zsh-completions')
-rw-r--r--app-shells/zsh-completions/Manifest4
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.34.0.ebuild31
-rw-r--r--app-shells/zsh-completions/zsh-completions-9999.ebuild8
3 files changed, 37 insertions, 6 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
index 1cba9dd142e0..b43facbcb8e1 100644
--- a/app-shells/zsh-completions/Manifest
+++ b/app-shells/zsh-completions/Manifest
@@ -1,4 +1,6 @@
DIST zsh-completions-0.33.0.tar.gz 285049 BLAKE2B bcbbb2966a48f1b8c06e14f14432e147b4a4ca28c7d9769b4a108e3d4e005c37874c93c836c8636dabb860780077ccc5d9ebbd339f63c34fd16975ec5486a5c4 SHA512 8eaa7d9d2a58e8e2daa6ba7d9a8498e607b271bfd0484184482ec610e7f647ca72ba945f6897b2d619918304a18d048c4b079dae0993dc660cba61d4bce1e0a3
+DIST zsh-completions-0.34.0.tar.gz 304543 BLAKE2B 75afed3059e889f92843099ad3eddae1f939a7d9a46d87a8048c5742b44699c2da13a9c2ea00ca2ea02898472199f064c420aac8943338e3b22189a7cc0d23b4 SHA512 643e967a77ab708c6316a9b43edd8b411f133aa4abe10bf69d3f5e545b2128423ad80d3509e7f9077b30cb8a83f60fe8d4355ed0a697dadffe1e1aaac6597c04
EBUILD zsh-completions-0.33.0.ebuild 843 BLAKE2B 0a8e51b5762f251b8c4325a550c15e3ae7fd4e76d4eb20b4606ff00c9589bb2f4b74c4d550a87ddf6cb7f12d5a574a0ba831b406f2fea1fef3923f736512bf93 SHA512 d703a7ec472e293b3460201c1c956e98f36fb449345e6e5f72b472ebc715806b12ff2991c02e0cb862eb050fb8018f3a984a762548146ce6fdfd255c9dc7e69a
-EBUILD zsh-completions-9999.ebuild 843 BLAKE2B 5f4b722e370ba04fb38b570f9eaa4b313387310ebc0e7dd4fe608fe1edf4552fc92a1094a13852f412d59d84aec1d270b1f8d4ff9625c047c819e11c5d81aec0 SHA512 c73d14bf57cd00995305cde21ffdf69c6630321d9a4b8cd0cc2953543d4133681932147c203859dbcd4bf75aeb186ca6c574f065fe147c37409785b4d132198b
+EBUILD zsh-completions-0.34.0.ebuild 838 BLAKE2B 27db4b4d68e5b4d9245ab2b46875a20aaa8595f8490c81f8a8ab1ba448a57be86c8c96c9586863fdb24f6ca2ea78c20c6df7f80b0959f43465aa0079682eb7e0 SHA512 a73b715fbc90e2fef9a092c2ad9c5bd5962892111fb23baf802083682c6c3c40522b5d8c13e5edf1900a149664cb012bf7f799d0ca33db2260a329d06c093c00
+EBUILD zsh-completions-9999.ebuild 838 BLAKE2B 27db4b4d68e5b4d9245ab2b46875a20aaa8595f8490c81f8a8ab1ba448a57be86c8c96c9586863fdb24f6ca2ea78c20c6df7f80b0959f43465aa0079682eb7e0 SHA512 a73b715fbc90e2fef9a092c2ad9c5bd5962892111fb23baf802083682c6c3c40522b5d8c13e5edf1900a149664cb012bf7f799d0ca33db2260a329d06c093c00
MISC metadata.xml 288 BLAKE2B 174d6d6870a6068602ca3be5fd6e935cbf74e0e548c94fe4a8809d41b453e82d811448bfc127307e7dadc92c841b6d8a3316af800a561c3a6ba75dd5e58e7030 SHA512 7ee80de6103ac19b2195a9bda9708a1f2b6ab2f38ca8f5d93d277b8fcbecadcc763802a8399fe038f7ed57f48a87ddd280d8a70f0ec0bb2c5b92c70fc7311842
diff --git a/app-shells/zsh-completions/zsh-completions-0.34.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.34.0.ebuild
new file mode 100644
index 000000000000..f5ebe5d49325
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.34.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="Apache-2.0 BSD MIT ZSH"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+}
diff --git a/app-shells/zsh-completions/zsh-completions-9999.ebuild b/app-shells/zsh-completions/zsh-completions-9999.ebuild
index ea096ae90a8d..f5ebe5d49325 100644
--- a/app-shells/zsh-completions/zsh-completions-9999.ebuild
+++ b/app-shells/zsh-completions/zsh-completions-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
else
SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
fi
DESCRIPTION="Additional completion definitions for Zsh"
@@ -25,9 +25,7 @@ src_install() {
}
pkg_postinst() {
- elog
elog "If you happen to compile your functions, you may need to delete"
elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
elog "to your shell."
- elog
}