summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
commit4b1be5ef874aaeb61a2116048e0c2312e53f8c69 (patch)
treee2f0118b102bf7e7ad852582d410adb43f13b035 /app-shells
parent4418da21bd05d610a3450f4aa75481785ca372a0 (diff)
gentoo auto-resync : 28:02:2025 - 19:27:52nextedge
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/Manifest.gzbin10644 -> 10640 bytes
-rw-r--r--app-shells/autojump/Manifest3
-rw-r--r--app-shells/autojump/autojump-22.5.3-r4.ebuild (renamed from app-shells/autojump/autojump-22.5.3-r3.ebuild)9
-rw-r--r--app-shells/autojump/files/22.5.3-Drop-pre-commit.patch29
4 files changed, 34 insertions, 7 deletions
diff --git a/app-shells/Manifest.gz b/app-shells/Manifest.gz
index 82efa8160105..214def71df4e 100644
--- a/app-shells/Manifest.gz
+++ b/app-shells/Manifest.gz
Binary files differ
diff --git a/app-shells/autojump/Manifest b/app-shells/autojump/Manifest
index 9ffed3e6e83d..dd5e02c8b519 100644
--- a/app-shells/autojump/Manifest
+++ b/app-shells/autojump/Manifest
@@ -1,4 +1,5 @@
+AUX 22.5.3-Drop-pre-commit.patch 600 BLAKE2B 437504c6362b275ffea0674fd903c304ddafa30e06aa1dd1a77031f0b0ea9317352deb9b04f914c03974d6f369b8c64b6d03dc7dbfaa0e47ba206daf832943ea SHA512 547cdb88b18f9880b83d841ac940a44eb66bacfa39545b522b38fbb67a46baf333ccf592da097d7dcd44dfa6b6fbcaf1f6d1ea931f4f6b0b0f41f01cb79e47bb
AUX 22.5.3-Use-mock-from-unittest.patch 689 BLAKE2B b0d518d66efb7511b8bbd8d31f5ce00c7561e90e259289a4dff051665c19bc9f3537cb04ed77e89d18c9b3fd6edcb6e0b912f0b9dfc9db1fc491b11a21957828 SHA512 a15cf9369527535dd475db53aa014108af2fe6cc72b04b166589c2c9d7464dd2eb999998aa8d55fc306bd6432b3926dc11caf00009b7b45562221957dc748dcd
DIST autojump-22.5.3.tar.gz 55429 BLAKE2B 3a2773669f81d1a54c01cce9fe75bc01609265998b035b4ba1aa064f1132acf852b59eb04ebfa744e628152f0ab478cbef24e5aff326bf84cec6e2c9348e8360 SHA512 d1dd3cbb67fda4e0a17ec5028b947faf46be8a95a6cd8418127b927f42bc95b71538a06658b38b479c77d147a6cd5e8cef77639ef538c7d449414c469c13f140
-EBUILD autojump-22.5.3-r3.ebuild 2041 BLAKE2B 173c4b3c3c2934932f16aa916256fbd8433fcea8a9287bcc1f749e900c6ec6419053a2c4888247fa34ea98ddf5e439ea48da098127d5926d3ee3e333f0b24ee3 SHA512 847b4a5a7f6941b698589d44203ebff25688209923acf32a8636c7ec9ba4c776a51cb381263ded481176cf1f6ebad1762ab2035d0ab70b0b05dc6fde65863072
+EBUILD autojump-22.5.3-r4.ebuild 2017 BLAKE2B a8c09ab2136327ec2da0cf2b9e71edc1afc5a58b5446fae26cb83aa54f7d5192c795f883109d55b5621f64adb1d31a6c00bfc96c593e7d42c122ee23cea5c876 SHA512 0494c4c75f226915413d747f12b62fad557653acd92885ad7ffc58b45188ae5a724c11dc9e93f3197561af08b2d97e64292da0ba97bee5f41cb44280504cbc8d
MISC metadata.xml 491 BLAKE2B 775beb745c9218ed955dca11149ccb5b17c3efacc8f916ca15a65f67632e01feac271d5a36c39316de8024f352427b658cf35e54f5d03682d681920b730af4bb SHA512 d26e3c132c90c94bae47c1f7a4af71eaf873a12546d429632736885c515764aa612fb8155003643678d2156b42e94a692b0e3174d2b4825b559426c29eaa863c
diff --git a/app-shells/autojump/autojump-22.5.3-r3.ebuild b/app-shells/autojump/autojump-22.5.3-r4.ebuild
index 521f272beb40..816a9201beda 100644
--- a/app-shells/autojump/autojump-22.5.3-r3.ebuild
+++ b/app-shells/autojump/autojump-22.5.3-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,16 +21,13 @@ REQUIRED_USE="ipython? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
RDEPEND="ipython? ( ${PYTHON_DEPS} )"
-DEPEND="${PYTHON_DEPS}
- test? (
- >=dev-vcs/pre-commit-0.7.0[${PYTHON_SINGLE_USEDEP}]
- )
-"
+DEPEND="${PYTHON_DEPS}"
distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}"/${PV}-Use-mock-from-unittest.patch
+ "${FILESDIR}"/${PV}-Drop-pre-commit.patch
)
src_prepare() {
diff --git a/app-shells/autojump/files/22.5.3-Drop-pre-commit.patch b/app-shells/autojump/files/22.5.3-Drop-pre-commit.patch
new file mode 100644
index 000000000000..cb0ce2a7c93f
--- /dev/null
+++ b/app-shells/autojump/files/22.5.3-Drop-pre-commit.patch
@@ -0,0 +1,29 @@
+From c625811d9a080a3b27c62cdbc05dbc0ff6b73855 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Fri, 28 Feb 2025 10:02:30 -0500
+Subject: [PATCH] Drop pre-commit
+
+---
+ tox.ini | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git ./tox.ini ./tox.ini
+index 8a21b97..0f08577 100644
+--- ./tox.ini
++++ ./tox.ini
+@@ -22,12 +22,5 @@ commands =
+ py.test -vv -rxs --tb native -s --strict {posargs:tests}
+ coverage report -m
+
+-
+-[testenv:pre-commit]
+-deps =
+- pre-commit>=0.7.0
+-commands =
+- pre-commit {posargs}
+-
+ [pytest]
+ norecursedirs = .git .tox docs
+--
+2.45.3
+