summaryrefslogtreecommitdiff
path: root/app-text/active-dvi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/active-dvi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/active-dvi')
-rw-r--r--app-text/active-dvi/Manifest4
-rw-r--r--app-text/active-dvi/active-dvi-1.10.2-r1.ebuild73
-rw-r--r--app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch13
-rw-r--r--app-text/active-dvi/metadata.xml8
4 files changed, 98 insertions, 0 deletions
diff --git a/app-text/active-dvi/Manifest b/app-text/active-dvi/Manifest
new file mode 100644
index 000000000000..094a3f3066d5
--- /dev/null
+++ b/app-text/active-dvi/Manifest
@@ -0,0 +1,4 @@
+AUX active-dvi-1.9-htmlcflags.patch 464 BLAKE2B d7e84e2a095f5aa5575f4dc78429106e9c695b077110965c96dab9b60b0f634c493a93f9a38996b7d282fbb4f21dca3e4115109d54ec01a0f93ee2b182fdc271 SHA512 994e7310097baececcb2f028041e66c6fb36e33a8fc6761ab2a73fb3c0d32999b92bdfdcc784366bf8f291070a5c5cc53ded072d7a562e2bdb8f559a21151d03
+DIST advi-1.10.2.tar.gz 9772060 BLAKE2B c9a96037d6101014688847bebf2c49eee94803064ef730fbc4f6729de6146672485d769cc4808cf947f8796145627dd47c4fc4cd7d406752ac77738905adcaa7 SHA512 93479e22261019b571bc331604a659e4e58200284bcdd63929b2c7ab07f8e9fabbd120f8876081a36e7e09e08286eeba9a45f3b077b545a9e404060622ec45c8
+EBUILD active-dvi-1.10.2-r1.ebuild 1602 BLAKE2B 3d3197ed45dfdaa59f029c940ea1545dffc954e4e2c681b1282c55085a749709f94965c2ad81753bd6d3b6e062943a157ebb02254be198aacc54c825b4361635 SHA512 eada2dcb6016d203db20996061e56f1466cc84d27fe9b7a17383029e9e2ab465a9b218fd7f6c5de76fa8808ee30aa272b7501cfbad7b963e73a1944bc792c5c5
+MISC metadata.xml 245 BLAKE2B ee3a163cfe0a4bc59c0dfb46f9ddb580e2d259b4d0e33cb4e684eb9e6d4b901bf97c6edd891f3b75a613a782f1b89318d0ee3ec9bee4e34c4441d9e8f4267678 SHA512 1653777623e2c15e1ce13229e396723b2cc9c214983e0f8592de98c01a31badc6c38c6735ed44f937d145883b43fb6f049af3eddb9ff96b18c96ccf8f67dd690
diff --git a/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild b/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild
new file mode 100644
index 000000000000..ab1bc39469ff
--- /dev/null
+++ b/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils autotools texlive-common
+
+MY_PN=${PN/ctive-/}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A DVI previewer and a presenter for slides written in LaTeX"
+SRC_URI="http://gallium.inria.fr/advi/${MY_P}.tar.gz"
+HOMEPAGE="http://gallium.inria.fr/advi/"
+LICENSE="LGPL-2.1"
+
+IUSE="+ocamlopt"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+RDEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]
+ >=dev-ml/camlimages-4.0.1:=[truetype,tiff,jpeg,postscript,X]
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ dev-texlive/texlive-pstricks
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-latexextra
+ x11-base/xorg-proto
+ dev-ml/findlib
+ app-text/htmlc
+ dev-tex/hevea"
+
+DOCS=( "README" "TODO" )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.9-htmlcflags.patch"
+ AT_M4DIR="." eautoreconf
+}
+
+src_configure() {
+ TEXMFMAIN="${EPREFIX}"/usr/share/texmf-site econf $(use_enable ocamlopt native-program) \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" --enable-dependency-tracking #486066
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ emake
+ cd doc || die
+ emake splash.dvi scratch_write_splash.dvi scratch_draw_splash.dvi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PACKAGE="${PF}" install
+
+ # now install the documentation
+ dodoc ${DOCS}
+
+ export STRIP_MASK="*/bin/advi.byt"
+
+ for i in "${ED}/usr/share/doc/${PF}/"*.dvi ; do
+ docompress -x /usr/share/doc/${PF}/$(basename $i)
+ done
+}
+
+pkg_postinst() {
+ etexmf-update
+}
+
+pkg_postrm() {
+ etexmf-update
+}
diff --git a/app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch b/app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch
new file mode 100644
index 000000000000..59697ec4dc83
--- /dev/null
+++ b/app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch
@@ -0,0 +1,13 @@
+Index: advi-1.9/doc/Makefile.am
+===================================================================
+--- advi-1.9.orig/doc/Makefile.am
++++ advi-1.9/doc/Makefile.am
+@@ -113,6 +113,8 @@ TEX_ENV = TEXINPUTS=$(srcdir):$(top_src
+ HEVEA_FLAGS = -entities -I $(srcdir) -I $(top_srcdir)/tex
+ HTMLC_FLAGS = -I $(srcdir)/includes \
+ -D CamlVersion '$(OCAMLVERSION)' \
++ -D HOSTNAME "$(HOSTNAME)" \
++ -D USER "$(USER)" \
+ -D version '$(VERSION)'
+
+ MV = mv -f
diff --git a/app-text/active-dvi/metadata.xml b/app-text/active-dvi/metadata.xml
new file mode 100644
index 000000000000..13170c3184d8
--- /dev/null
+++ b/app-text/active-dvi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+</maintainer>
+</pkgmetadata>