summaryrefslogtreecommitdiff
path: root/app-text/aiksaurus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /app-text/aiksaurus
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'app-text/aiksaurus')
-rw-r--r--app-text/aiksaurus/Manifest2
-rw-r--r--app-text/aiksaurus/aiksaurus-1.2.1-r1.ebuild41
-rw-r--r--app-text/aiksaurus/files/aiksaurus-1.2.1-format-security.patch29
3 files changed, 72 insertions, 0 deletions
diff --git a/app-text/aiksaurus/Manifest b/app-text/aiksaurus/Manifest
index 93897e5f7cce..a3068083921a 100644
--- a/app-text/aiksaurus/Manifest
+++ b/app-text/aiksaurus/Manifest
@@ -1,4 +1,6 @@
+AUX aiksaurus-1.2.1-format-security.patch 822 BLAKE2B f8891b9772367ce4aef4b68e3af122826d7250d9cec4df9ef48a3564cb522911d56710394eaa183b6180e08eae939b9f00a73fe061f21be4142520689687ad4c SHA512 72ebdc63cbb2c56bd8274f92501cbbae8c66e7d81b11b8fdeda38149da4bf44ab88699d248093eedc9813f6cd60e2a1f360fb39d778b4b7827777b1d003ab1dc
AUX aiksaurus-1.2.1-gcc43.patch 734 BLAKE2B 9c8b5c401bc116d9daa52ee100bd42127639330449b44d0012494fd8536d46dd99079ee606df794b515ae002d5834f379706af7ecb41785593be150842baaa53 SHA512 6f821ac66f0dd4601f84a6fe8f71b14712854e293f4ebc755a80d34032725cee61b919da1547b514e3d8b6a07edd29016ae53283a28f1792119ae99850016241
DIST aiksaurus-1.2.1.tar.gz 928893 BLAKE2B 12bcc77eccd921e4e2dd3f148be76905bb162a38483b0aee620be2fe069685a4289df4ec12f91286eb88d9c2f1f4d58556b0b6ac38857fe4f11bb5d31adff496 SHA512 48591850f28f1a8f4b4986df14090ef7bd57cbfbad739cb0013db021f6f5bcb3c592b38e36774735499e27b9e99330504f8d9c6022158e25469cbc81d13f7463
+EBUILD aiksaurus-1.2.1-r1.ebuild 921 BLAKE2B 51857e2551a12d4b508305888552bb6d58f4a8a2b4ea2e3d72fc086402be3698e39a156b3387fbfa3cf53940cc7c8bf16ede10d06bb5fbd62f632f92220d1144 SHA512 bc42edc981b8bc886e1024d5f0e8ae1a423a2a06e29d39faca6b3c334bfaeda249ba0d9e36252e929530b5e8bc3ee443e8ae8a0a167bc7037d890ecd3d1dbde4
EBUILD aiksaurus-1.2.1.ebuild 803 BLAKE2B 4ea59eb9cd6bb4513091a92c72d346ec18cda4690b0bc5d3903e84fe57063f9ac6b3bbfee731dc48d51d906b8b26b012f84af146d9f11011e6f30d8bf10d7a52 SHA512 f442673ae7806af431baa5d49c7eef26aabce69935b22e26255547e25737b03501e6096b82f80db49c07b78e43e45fcc65ecc6bb3eaa4daef52388d3a55cd9b4
MISC metadata.xml 245 BLAKE2B 163eaf1f9854d0f7906920339f1ddf8321c4658b23e14d44bdc7e07ea3eba22d7cedb1cc63285aff307a1287555463807160d380836d63032637eacd5ce97f1d SHA512 34945e0950bf668d24db2565287fdd8484cccb8968df2efbcc665905ee583f45222fe0ff848c267cf9a25f58d3aae9e870656d88b1f813b7812a185782564e08
diff --git a/app-text/aiksaurus/aiksaurus-1.2.1-r1.ebuild b/app-text/aiksaurus/aiksaurus-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..b78d34eacee5
--- /dev/null
+++ b/app-text/aiksaurus/aiksaurus-1.2.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic libtool
+
+DESCRIPTION="A thesaurus lib, tool and database"
+HOMEPAGE="https://sourceforge.net/projects/aiksaurus"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="gtk"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc43.patch"
+ "${FILESDIR}/${P}-format-security.patch"
+)
+
+src_prepare() {
+ default
+ # Needed to make relink work on FreeBSD, without it won't install.
+ # Also needed for a sane .so versionning there.
+ elibtoolize
+}
+
+src_configure() {
+ filter-flags -fno-exceptions
+ econf $(use_with gtk)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/aiksaurus/files/aiksaurus-1.2.1-format-security.patch b/app-text/aiksaurus/files/aiksaurus-1.2.1-format-security.patch
new file mode 100644
index 000000000000..ba90a4519502
--- /dev/null
+++ b/app-text/aiksaurus/files/aiksaurus-1.2.1-format-security.patch
@@ -0,0 +1,29 @@
+--- aiksaurus-1.2.1/base/caiksaurus.cpp.orig 2014-06-07 21:14:03.869649696 +0100
++++ aiksaurus-1.2.1/base/caiksaurus.cpp 2014-06-07 21:33:06.241471066 +0100
+@@ -254,7 +254,7 @@
+ /* see if we got --version. */
+ if ( !strcmp(arg, "--version") || !strcmp(arg, "-v") )
+ {
+- printf(version);
++ printf("%s", version);
+ exit(0);
+ }
+
+@@ -262,7 +262,7 @@
+ else if ( !strcmp(arg, "--help") || !strcmp(arg, "-h") )
+ {
+ printf("Usage: %s [word]\n\n", argv[0]);
+- printf(help);
++ printf("%s", help);
+ exit(0);
+ }
+ }
+@@ -271,7 +271,7 @@
+ if (argc != 2)
+ {
+ printf("Usage: %s [word]\n", argv[0]);
+- printf(help);
++ printf("%s", help);
+ exit(1);
+ }
+ }