summaryrefslogtreecommitdiff
path: root/app-text/binfind
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
commita4f9ab81d6cbfc3ff649dd3577e3efa700b47387 (patch)
tree1c6cf78322fbf3379d5b7e4f4b836a42c5fddd19 /app-text/binfind
parenta4e37a9aeeef82eba5858dbc609f65b838b0f836 (diff)
gentoo auto-resync : 06:10:2022 - 01:20:42
Diffstat (limited to 'app-text/binfind')
-rw-r--r--app-text/binfind/Manifest3
-rw-r--r--app-text/binfind/binfind-0.0.3.ebuild17
-rw-r--r--app-text/binfind/files/binfind-0.0.3-clang16.patch9
3 files changed, 25 insertions, 4 deletions
diff --git a/app-text/binfind/Manifest b/app-text/binfind/Manifest
index a6dce979a2ec..790634047e7f 100644
--- a/app-text/binfind/Manifest
+++ b/app-text/binfind/Manifest
@@ -1,3 +1,4 @@
+AUX binfind-0.0.3-clang16.patch 178 BLAKE2B ec23e6dbb28dd7cdd40c3bc955c4d69178e7452768dc543bb3a24461b569e485dea2f0cc0e414ec0ddf86a0fe3533d31536c7f181d799875ebc16e07dc461ea3 SHA512 5028624b4ac83d942a6458bbc9155bf532fb799b619db35a3be7150bcaf51c83cdc22e3176e780421598dd22478ca26bd44a1d4a273a25043b465365c7b2e324
DIST binfind-0.0.3.tar.gz 91222 BLAKE2B 87ab9faa611064b87771d5ddd799b792e27af457e5a768b4ee7c0f3976c41ed8692673a753b95450124ad0c3c8e5e473081961482b856dfb8e722323915d04d7 SHA512 b3a8b72669f701ce54fb3d1c2331262cfc7f396239d14741d3a106c999ef58739a7f33de87da427983ffb641baa7fae4857aa6aab2e1c0748a61d8b913dca3f1
-EBUILD binfind-0.0.3.ebuild 345 BLAKE2B 41d5a675f441c21d9239b56f284109f846fd67681907d5ee7df24290dcc7f9e62ecd1f2b2ab82ddd985a0cde429795e5db776b4a471ff06d3437fa42a60f92d3 SHA512 0cd631f5002ab8e47c9d5db0fc11ea133b2c2e1ab85c66643605f7a7b29175598c0711c0bc7d847bb64f8d822ef4396b6e4eecd84dd453362102d07e6b62cb4b
+EBUILD binfind-0.0.3.ebuild 453 BLAKE2B e8124244c374ec50b4e9cbcebd41a1cab11de22001d1cf1966cbfc29a0af8112ec6cc8f5856758f79191c03eaa0a91bf22c36e886b20c47e09c69ce6f7e7e29b SHA512 a96eb209493fe61ceda2a60048005bff4b8060e999cdb9f1a4bfe4a2c02dbc0f3fa55b18cd5241cc1680720882f6aaf5f502b8efd75a23a99bec4dcc8cc35053
MISC metadata.xml 217 BLAKE2B fbec54484edc2603e95c90cb231985ef0f5f8d2cd48632ac8a097a4dac165499ff4cc087b1ca9ba6a4368bbb73b3af1ee99622a80df17072e1a340c345a2ee64 SHA512 7d3fc456b183fe7bdea26fb6edce39f702741a762b74cd7d2159a0ba85af50ebc87fbd921c926692a6164d50c9faf6b19680ab96528819bb06aaeac679e42de2
diff --git a/app-text/binfind/binfind-0.0.3.ebuild b/app-text/binfind/binfind-0.0.3.ebuild
index 98b9511f6370..fce82cc6b67d 100644
--- a/app-text/binfind/binfind-0.0.3.ebuild
+++ b/app-text/binfind/binfind-0.0.3.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="Search files for a byte sequence specified on the command line"
HOMEPAGE="https://www.lith.at/binfind/"
@@ -10,4 +12,13 @@ SRC_URI="https://www.lith.at/binfind/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"
-IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf #870832
+}
diff --git a/app-text/binfind/files/binfind-0.0.3-clang16.patch b/app-text/binfind/files/binfind-0.0.3-clang16.patch
new file mode 100644
index 000000000000..12a7174ec0e9
--- /dev/null
+++ b/app-text/binfind/files/binfind-0.0.3-clang16.patch
@@ -0,0 +1,9 @@
+https://bugs.gentoo.org/870832
+--- a/configure.in
++++ b/configure.in
+@@ -26,4 +26,5 @@
+ [#include <stdio.h>
+ #include <stdlib.h>
++ #include <string.h>
+
+ int main(void)