summaryrefslogtreecommitdiff
path: root/app-text/blahtexml/blahtexml-0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-text/blahtexml/blahtexml-0.9.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-text/blahtexml/blahtexml-0.9.ebuild')
-rw-r--r--app-text/blahtexml/blahtexml-0.9.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/app-text/blahtexml/blahtexml-0.9.ebuild b/app-text/blahtexml/blahtexml-0.9.ebuild
index 7a32d14559cd..f470b6197643 100644
--- a/app-text/blahtexml/blahtexml-0.9.ebuild
+++ b/app-text/blahtexml/blahtexml-0.9.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="TeX-to-MathML converter"
HOMEPAGE="http://gva.noekeon.org/blahtexml"
@@ -15,16 +15,24 @@ KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 x86"
IUSE="doc"
RDEPEND="dev-libs/xerces-c"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
doc? (
app-text/texlive-core
dev-libs/libxslt
- dev-tex/latex2html )"
+ dev-tex/latex2html
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-{Makefile,gcc-4.7}.patch
+)
src_prepare() {
- tc-export CC CXX
- epatch "${FILESDIR}"/${P}-{Makefile,gcc-4.7}.patch
+ default
+
+ tc-export CC CXX PKG_CONFIG
}
src_compile() {