summaryrefslogtreecommitdiff
path: root/app-text/bogosort/bogosort-0.4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/bogosort/bogosort-0.4.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/bogosort/bogosort-0.4.2-r1.ebuild')
-rw-r--r--app-text/bogosort/bogosort-0.4.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/bogosort/bogosort-0.4.2-r1.ebuild b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..5eff84f8ed58
--- /dev/null
+++ b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A file sorting program which uses the bogosort algorithm"
+HOMEPAGE="http://www.lysator.liu.se/~qha/bogosort/"
+SRC_URI="ftp://ulrik.haugen.se/pub/unix/bogosort/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ~mips ppc sparc x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/xmalloc.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
+src_configure() {
+ tc-export CC
+ econf || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README NEWS ChangeLog AUTHORS || die
+}