summaryrefslogtreecommitdiff
path: root/app-text/chasen/chasen-2.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-text/chasen/chasen-2.4.5.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-text/chasen/chasen-2.4.5.ebuild')
-rw-r--r--app-text/chasen/chasen-2.4.5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-text/chasen/chasen-2.4.5.ebuild b/app-text/chasen/chasen-2.4.5.ebuild
new file mode 100644
index 000000000000..d7433b71a1f0
--- /dev/null
+++ b/app-text/chasen/chasen-2.4.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit perl-module
+
+DESCRIPTION="Japanese Morphological Analysis System, ChaSen"
+HOMEPAGE="https://chasen-legacy.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}-legacy/56305/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 ~riscv x86 ~sparc-solaris"
+IUSE="perl static-libs"
+
+RDEPEND="virtual/libiconv"
+DEPEND=">=dev-libs/darts-0.32"
+PDEPEND=">=app-dicts/ipadic-2.7.0"
+
+PATCHES=( "${FILESDIR}"/${PN}-uar.patch )
+
+src_configure() {
+ econf $(use_enable static-libs static)
+
+ if use perl; then
+ cd "${S}"/perl || die
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ cd "${S}"/perl || die
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ default
+
+ if use perl; then
+ cd "${S}"/perl || die
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ if use perl; then
+ cd "${S}"/perl || die
+ perl-module_src_install
+ newdoc README README.perl
+ fi
+}