summaryrefslogtreecommitdiff
path: root/app-text/cherrytree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/cherrytree
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/cherrytree')
-rw-r--r--app-text/cherrytree/Manifest3
-rw-r--r--app-text/cherrytree/cherrytree-0.37.0.ebuild55
-rw-r--r--app-text/cherrytree/metadata.xml8
3 files changed, 66 insertions, 0 deletions
diff --git a/app-text/cherrytree/Manifest b/app-text/cherrytree/Manifest
new file mode 100644
index 000000000000..989d47be2539
--- /dev/null
+++ b/app-text/cherrytree/Manifest
@@ -0,0 +1,3 @@
+DIST cherrytree-0.37.0.tar.gz 8888703 BLAKE2B 737c0c247c581086e23e4c3e5fba0b18459788b385078ec8092af8b7352d77c8b273c939f702178d0ae59c8633bf996a7a7e5223e22da703ced3c8bf1d7cbde3 SHA512 a1aaf92657c58c70430a45adaa771050b43476bc2a33dc929b108842d5ef46aa83c4fa4cfe8c4f54a9a3656fc0d30046fae34cbac5aa9fe3f32aa539058636f5
+EBUILD cherrytree-0.37.0.ebuild 1191 BLAKE2B 106630e09107a750bed11980bcb458fc39e194e7a6b03a3bd2d0a045ca84ba5e34f1337f92f3dad2e36a4f2c1cb979e6dfafa6a6434febf569ae482747ad26a5 SHA512 2cdb77421a542d6070be7fa933de3c083c0865f6cc58d93815ee9faf52c47f34154eb4acd7f0c6edea7c091e243789ee7824256ef947c725c3c78b5248de5e19
+MISC metadata.xml 250 BLAKE2B 9676935c062d76f3e06a49612672d533ba7f431e0819084758da368a632e3cdfbaa68da7e367b0847ed2e66db4e5a41377dd80819cca08af3dbce53fb3622d36 SHA512 c9d9bb6db803a0958073fb76a3d26192374ec85b66ccddaac01829afea556302126f99dc6158d71ae4cc9e5152da0ce203ad527ffe923edb6239c7ff43e19a76
diff --git a/app-text/cherrytree/cherrytree-0.37.0.ebuild b/app-text/cherrytree/cherrytree-0.37.0.ebuild
new file mode 100644
index 000000000000..70d1db48a137
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-0.37.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=true
+
+inherit xdg distutils-r1
+
+DESCRIPTION="A hierarchical note taking application"
+HOMEPAGE="https://www.giuspen.com/cherrytree"
+LICENSE="GPL-3"
+
+SLOT="0"
+SRC_URI="https://github.com/giuspen/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ x11-libs/libX11
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.16:2[${PYTHON_USEDEP}]
+ dev-python/pygtksourceview:2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+PLOCALES="cs de es fr hy it ja lt nl pl pt_BR ru sl tr uk zh_CN"
+inherit l10n
+
+python_prepare_all() {
+ xdg_src_prepare
+
+ if use nls ; then
+ l10n_find_plocales_changes 'locale' '' '.po'
+
+ rm_loc() {
+ rm -v -f "locale/${1}.po" || return 1
+ }
+ l10n_for_each_disabled_locale_do rm_loc
+ fi
+
+ sed -r -e '/\bupdate-desktop-database\b/d' -i -- 'setup.py' || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ use nls || mydistutilsargs+=( --without-gettext )
+}
diff --git a/app-text/cherrytree/metadata.xml b/app-text/cherrytree/metadata.xml
new file mode 100644
index 000000000000..e69a8d811bcb
--- /dev/null
+++ b/app-text/cherrytree/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">giuspen/cherrytree</remote-id>
+ </upstream>
+</pkgmetadata>