summaryrefslogtreecommitdiff
path: root/app-text/clara
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/clara
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/clara')
-rw-r--r--app-text/clara/Manifest6
-rw-r--r--app-text/clara/clara-20031214-r1.ebuild54
-rw-r--r--app-text/clara/clara-20031214.ebuild55
-rw-r--r--app-text/clara/files/clara-20031214-debian-vararg.patch90
-rw-r--r--app-text/clara/files/clara_open_mode.patch20
-rw-r--r--app-text/clara/metadata.xml5
6 files changed, 230 insertions, 0 deletions
diff --git a/app-text/clara/Manifest b/app-text/clara/Manifest
new file mode 100644
index 000000000000..71f33045643d
--- /dev/null
+++ b/app-text/clara/Manifest
@@ -0,0 +1,6 @@
+AUX clara-20031214-debian-vararg.patch 1768 BLAKE2B 87457b832c224a4a199136abda7a8448fb80ec215d7d93a5f66a0d382b8bc3dc0a33412954a91040b5ed6a8a9e4d24619ff783b05b32481f2c6da694cc2fee5c SHA512 3ec7c2bb9a11721c670ac1f74f2038f0909d0282392381be8c2bb2b9fd564b32dc94b56ab9458d95a63bf701816729610501e8cea2ca9088f64db62f560611bb
+AUX clara_open_mode.patch 567 BLAKE2B 0b355d1ef6a2c8de21e2c90b4651d361799ce6d4972a1a235068d2d08fd0810d712bde3e3d759ce1305f9c52c094120e7e42bbfb6b1c332ccbcded64dcb64c5a SHA512 787972048c6ddcea4727b72a0b327486349876de2978358fcc4386010d5f43415e6573bf01d4c48ad747195718186954403ddae63a09f1bf5471995b17d27b34
+DIST clara-20031214.tar.gz 451539 BLAKE2B beed8b3a199825a8d8699c10b6a08c4d71fbafa3f3d2ebbbff6b13eafa35b4f38bacca35209039a93f0d31a993987a8773371b43440a1a0fbd61c40c455ec1f9 SHA512 260d710132a3903d71b6c4c0885ac1709b60d520861e3dcd5e4b75a3bf5627549c94423670be08245e7a9db6a870a93a9526c8d318fadaddcce00cbf02985f49
+EBUILD clara-20031214-r1.ebuild 1262 BLAKE2B ba3f6b45e1d17a56066134acf5991837d3e3fd92c6edf7ebf71833254d8c9f6eaa58b1369029d7a388a3dbb256cca75ae3d6804107fffac14f7361f6e95bfb6e SHA512 499a121d78c780e025ba45b9f56e1e8b8c16d7776ec2b21b1bd1af5b60b4c1526f5bd443c19ea697c12d5c7d519e902a17a15756c3d42f1cbe2972c49773335b
+EBUILD clara-20031214.ebuild 1245 BLAKE2B 46d3e3ea7114342eec8a8b6d298e41ceea7eb05a0af31ab7247daab97fe5645561cfcec96edb3886078548546ed6691783e802102935fca3520a151713ebd23d SHA512 e14f2c63eba3aa5dd9a3300b65bec2a0f263546dd778ec5ee826a6dc90d44dde778505abcaf21eeb8b7904e92f4fa7ab2f27aabee38d4505410bba29495d5a8e
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/clara/clara-20031214-r1.ebuild b/app-text/clara/clara-20031214-r1.ebuild
new file mode 100644
index 000000000000..758415dfd6af
--- /dev/null
+++ b/app-text/clara/clara-20031214-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An OCR (Optical Character Recognition) program"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://www.claraocr.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+# The test provided by clara doesn't seem to make any sense. It just
+# calls the binary with an unsupported option, which results in an
+# error.
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -re "s/(C|LD)FLAGS =/\1FLAGS +=/" Makefile
+ epatch "${FILESDIR}/${PN}_open_mode.patch"
+ epatch "${FILESDIR}/${P}-debian-vararg.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+ emake doc || die
+}
+
+src_install() {
+ dobin ${PN} selthresh
+ doman doc/${PN}*.1 selthresh.1
+
+ dodoc ANNOUNCE CHANGELOG doc/FAQ
+ insinto /usr/share/doc/${P}
+ doins imre.pbm
+
+ dohtml doc/*.html
+}
+
+pkg_postinst() {
+ elog
+ elog "Please note that Clara OCR has to be trained to recognize text,"
+ elog "without a training session it simply won't work. Have a look at"
+ elog "the docs in /usr/share/doc/${P}/html/ to get more "
+ elog "info about the training procedure."
+ elog
+}
diff --git a/app-text/clara/clara-20031214.ebuild b/app-text/clara/clara-20031214.ebuild
new file mode 100644
index 000000000000..e1143a5a99b2
--- /dev/null
+++ b/app-text/clara/clara-20031214.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An OCR (Optical Character Recognition) program"
+SRC_URI="mirror://gentoo/clara-20031214.tar.gz"
+HOMEPAGE="http://www.claraocr.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86 ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+# The test provided by clara doesn't seem to make any sense. It just
+# calls the binary with an unsupported option, which results in an
+# error.
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -re "s/(C|LD)FLAGS =/\1FLAGS +=/" Makefile
+ epatch "${FILESDIR}/clara_open_mode.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+ emake doc || die
+}
+
+src_install() {
+ dobin clara selthresh
+ doman doc/clara*.1 selthresh.1
+
+ dodoc ANNOUNCE CHANGELOG doc/FAQ
+ insinto /usr/share/doc/${P}
+ doins imre.pbm
+
+ dohtml doc/*.html
+}
+
+pkg_postinst() {
+ elog
+ elog "Please note that Clara OCR has to be trained to recognize text,"
+ elog "without a training session it simply won't work. Have a look at"
+ elog "the docs in /usr/share/doc/${P}/html/ to get more "
+ elog "info about the training procedure."
+ elog
+}
diff --git a/app-text/clara/files/clara-20031214-debian-vararg.patch b/app-text/clara/files/clara-20031214-debian-vararg.patch
new file mode 100644
index 000000000000..570bc4018993
--- /dev/null
+++ b/app-text/clara/files/clara-20031214-debian-vararg.patch
@@ -0,0 +1,90 @@
+--- clara-20031214.orig/clara.c
++++ clara-20031214/clara.c
+@@ -751,11 +751,12 @@
+ s[128] = 0;
+ logmsg(s);
+
+- if (!trace)
+- return;
+- va_start(args,m);
+- vfprintf(stderr,m,args);
+- fprintf(stderr,"\n");
++ if (trace) {
++ vfprintf(stderr,m,args);
++ fprintf(stderr,"\n");
++ }
++
++ va_end(args);
+ }
+
+ /*
+@@ -775,10 +776,12 @@
+ logmsg(s);
+
+ /* send to stderr if requested */
+- if (!debug)
+- return;
+- vfprintf(stderr,m,args);
+- fprintf(stderr,"\n");
++ if (debug) {
++ vfprintf(stderr,m,args);
++ fprintf(stderr,"\n");
++ }
++
++ va_end(args);
+ }
+
+ /*
+@@ -797,9 +800,10 @@
+ s[128] = 0;
+ logmsg(s);
+
+- va_start(args,m);
+ vfprintf(stderr,m,args);
+ fprintf(stderr,"\n");
++
++ va_end(args);
+ }
+
+ /* (devel)
+--- clara-20031214.orig/event.c
++++ clara-20031214/event.c
+@@ -638,6 +638,8 @@
+ }
+ }
+
++ va_end(args);
++
+ /*
+ printf("request (priority %d, mclip=%d, redraw=%d) to draw the message \"%s\"\n",f,mclip,redraw_stline,s);
+ */
+--- clara-20031214.orig/html.c
++++ clara-20031214/html.c
+@@ -1548,11 +1548,12 @@
+ va_list args;
+ int n=0,f;
+
+- va_start(args, fmt);
+ for (f=0; f==0; ) {
+
+ /* try to write */
++ va_start(args, fmt);
+ n = vsnprintf(*t+*top+1,*sz-*top-1,fmt,args);
++ va_end(args);
+
+ /*
+ Some implementations of vsnprintf return -1 when
+@@ -1589,11 +1590,12 @@
+ va_list args;
+ int n=0,f;
+
+- va_start(args, fmt);
+ for (f=0; f==0; ) {
+
+ /* try to write */
++ va_start(args, fmt);
+ n = vsnprintf(text+topt+1,textsz-topt-1,fmt,args);
++ va_end(args);
+
+ /*
+ Some implementations of vsnprintf return -1 when
diff --git a/app-text/clara/files/clara_open_mode.patch b/app-text/clara/files/clara_open_mode.patch
new file mode 100644
index 000000000000..3f73f466ab8c
--- /dev/null
+++ b/app-text/clara/files/clara_open_mode.patch
@@ -0,0 +1,20 @@
+--- pgmblock.c 2002-04-29 14:26:13.000000000 +0000
++++ pgmblock.c 2009-03-05 02:51:43.000000000 +0000
+@@ -161,7 +161,7 @@
+
+ printf("%d rare pixels (%1.4f)\n",t,((float)t)/(w*h));
+
+- F = open("map",O_WRONLY|O_CREAT);
++ F = open("map",O_WRONLY|O_CREAT, 0644);
+ write(F,m,h*bpl);
+ write(F,map,256);
+ close(F);
+@@ -197,7 +197,7 @@
+ {
+ int i,j,F;
+
+- F = open("map",O_RDONLY|O_CREAT);
++ F = open("map",O_RDONLY|O_CREAT, 0644);
+ read(F,m,h*bpl);
+ read(F,map,256);
+ close(F);
diff --git a/app-text/clara/metadata.xml b/app-text/clara/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-text/clara/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>