summaryrefslogtreecommitdiff
path: root/app-text/crf++/crf++-0.58.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/crf++/crf++-0.58.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/crf++/crf++-0.58.ebuild')
-rw-r--r--app-text/crf++/crf++-0.58.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-text/crf++/crf++-0.58.ebuild b/app-text/crf++/crf++-0.58.ebuild
new file mode 100644
index 000000000000..7518e894e2e9
--- /dev/null
+++ b/app-text/crf++/crf++-0.58.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+inherit autotools eutils
+
+MY_P="${P/crf/CRF}"
+DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
+HOMEPAGE="https://crfpp.googlecode.com/svn/trunk/doc/index.html"
+SRC_URI="https://crfpp.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="examples static-libs"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) || die
+}
+
+src_test() {
+ for task in example/* ; do
+ (
+ cd "${task}"
+ ./exec.sh || die "failed test in ${task}"
+ )
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ dodoc AUTHORS README || die
+ dohtml -r doc/* || die
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r example || die
+ fi
+}