summaryrefslogtreecommitdiff
path: root/app-text/dblatex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-15 04:04:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-15 04:04:09 +0100
commit45392c898b8ba163e95028bd98896e77f0c73806 (patch)
treebf6b64dd472acc2960a5c24b26dd0ac036b47d0d /app-text/dblatex
parent2916cf6049cf9d3092021e247d56c580df6029a7 (diff)
gentoo auto-resync : 15:10:2024 - 04:04:09
Diffstat (limited to 'app-text/dblatex')
-rw-r--r--app-text/dblatex/Manifest1
-rw-r--r--app-text/dblatex/dblatex-0.3.12-r4.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-text/dblatex/Manifest b/app-text/dblatex/Manifest
index 108941260bed..52a2f053ad36 100644
--- a/app-text/dblatex/Manifest
+++ b/app-text/dblatex/Manifest
@@ -8,4 +8,5 @@ AUX dblatex-0.3.12-replace-imp-by-importlib.patch 3883 BLAKE2B a747ece1ec3717ba1
DIST dblatex3-0.3.12.tar.bz2 1693272 BLAKE2B 9310ce5db3b5f92e183f2656c5b1881edaf0208ae4f78f853332c844258fa38d443921fc42c03301773b1451ce272a538c305d765acbdc6eafbdcf25ebf5d2d3 SHA512 5bfa774c8dbe362775f6bbb5e1196e5a2bb1af239778133c12ddc725406ced67f3ff422433a2a1aa02d4431e9be58ba12e918379deb81fcd5b96533d2bdf029a
EBUILD dblatex-0.3.12-r2.ebuild 1981 BLAKE2B f1b2547b670fb94ad68479fa313f179f13e1f79838bb1b1a95905314dd984b1287e3bdca7f49d57305de7df5e3ea6a5f0b402a4da020b35bb5f383e76762ebcf SHA512 81e0d4f295a293ebdb08ae058ecf6af2bd104226449c0722bed0937b5b7abb49d4cc5d8a3c7bd0f021b3897dd99b24ba4862a52104025fbcbde192ecdcc52ebf
EBUILD dblatex-0.3.12-r3.ebuild 2482 BLAKE2B 4f21e3e5f0d3be85ecb31e6825f98ad66be961a88461e13106228506b5e4adab4310f23fab9e1da8cec6e3d39e0f41c75355808eb1e4788dfd60e6ac3d627cc9 SHA512 2257a80fd0ee4335b7d6ab866e01ae7886e53b43796f4268cf04cda19595360ab4677a88c7106b9b8716aa2c027f485fbed5c55038b9281cd455d343e404029f
+EBUILD dblatex-0.3.12-r4.ebuild 2489 BLAKE2B 0edb4c09298248f0533fd998ba65cf7df76ae3883284f31f42979888e4dc48dedfac36c4f24d31187d6b7e2d7536dd00eadb9eef722ceff2c9ea1e76c23f1bcd SHA512 9d5008490a6b5873d55b51953c8c307810ddd5598ad117385ae1522d36692ee5c4f1629522e162685b92a9e25214741b7232962a68d11008c2bce8b3d151ed7b
MISC metadata.xml 908 BLAKE2B e13f176739b3fb7a63a5eaeb704afa1c0b4e9740ea25dec54656c283cf9f8f614096aae407df8822414e054eaad0082c738c0a5a2acc91a51ce3f6b729fc37d6 SHA512 a39c4073b4cec1753724d16bcca023c9306eeac79bc7f008c6e090f85c4661733810c9864b91b9552fbbec242c01a312780ee780d11724ce26399bad3c9a0899
diff --git a/app-text/dblatex/dblatex-0.3.12-r4.ebuild b/app-text/dblatex/dblatex-0.3.12-r4.ebuild
new file mode 100644
index 000000000000..4766dc378243
--- /dev/null
+++ b/app-text/dblatex/dblatex-0.3.12-r4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Transform DocBook using TeX macros"
+HOMEPAGE="https://dblatex.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/project/dblatex/dblatex/${P}/${PN}3-${PV}.tar.bz2"
+S="${WORKDIR}/${PN}3-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="inkscape test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/kpathsea
+ dev-libs/libxslt
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-xetex
+ gnome-base/librsvg
+ virtual/imagemagick-tools
+ >=media-gfx/fig2dev-3.2.9-r1
+ inkscape? ( media-gfx/inkscape )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( ~${CATEGORY}/${P}[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.11-path-logging.patch"
+ "${FILESDIR}/${PN}-0.3.11-setup.patch"
+ "${FILESDIR}/${PN}-0.3.11-encode.patch"
+ "${FILESDIR}/${P}-replace-imp-by-importlib.patch"
+ "${FILESDIR}/${P}-adjust-submodule-imports.patch"
+)
+
+python_prepare_all() {
+ # Manual page is precomressed, but we will use our own compression later.
+ gunzip docs/manpage/dblatex.1.gz || die
+ if use inkscape; then
+ # If we use inscape we want to make dblatex compatible with v1.0
+ eapply "${FILESDIR}/${PN}-0.3.11-inkscape-1.0.patch"
+ else
+ # If we don't have inkscape we need to use an alternative SVG converter
+ eapply "${FILESDIR}/${PN}-0.3.11-no-inkscape-dependency.patch"
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # After migrating to PEP517 setuptool's distutils behaves a bit differently.
+ # Rather than rewriting the entire build setup we follow Debian's path with
+ # a predefined script.
+ python_newscript - dblatex <<-EOF
+ #!${EPREFIX}/usr/bin/python
+ import sys
+ import os
+
+ package_base = r"${EPREFIX}/usr/share/dblatex"
+
+ from dbtexmf.dblatex import dblatex
+ dblatex.main(base=package_base)
+ EOF
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # Move package documentation to a folder name containing version number
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+}
+
+python_test() {
+ emake -C tests/mathml
+}