summaryrefslogtreecommitdiff
path: root/app-text/diffpdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-07 18:44:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-07 18:44:07 +0000
commit5001a6c7b6da2956f5b17c695b1e0059dc7b8de5 (patch)
tree0528a53855a7ec96d20cde9edb9031aab030224c /app-text/diffpdf
parenta8b0d35ab742f31538d515dea39716e566d533c0 (diff)
gentoo resync : 07.01.2018
Diffstat (limited to 'app-text/diffpdf')
-rw-r--r--app-text/diffpdf/Manifest4
-rw-r--r--app-text/diffpdf/diffpdf-2.1.3-r1.ebuild39
-rw-r--r--app-text/diffpdf/diffpdf-2.1.3.ebuild36
-rw-r--r--app-text/diffpdf/files/diffpdf-2.1.3-qt5.patch173
-rw-r--r--app-text/diffpdf/files/diffpdf.desktop9
5 files changed, 224 insertions, 37 deletions
diff --git a/app-text/diffpdf/Manifest b/app-text/diffpdf/Manifest
index a7ccbc765da2..10492097d14b 100644
--- a/app-text/diffpdf/Manifest
+++ b/app-text/diffpdf/Manifest
@@ -1,3 +1,5 @@
+AUX diffpdf-2.1.3-qt5.patch 6240 BLAKE2B c4f522b41e4b036222f832e194088d2377f5063d35e8eb73714745db7a993d9b38fd9e5111eee69d7f2d86710a45289a8e54d25b8a3217b1ddd2fe53bd59b468 SHA512 96ae465bb5b27ff0b26a7c4686e7656af025669b418b755878627b1baf4b91bf14833e951f80c6510d907419efdb8759dffca3f5b7fb517b5bf20ae1ee6b3406
+AUX diffpdf.desktop 152 BLAKE2B e85754380c3e607d6bfe0f4db875983596f8e562d48b8bb732e26a23f9cb6137d7ec700ac2d0596fa3a13d79b6c527de671f46825646e266cf5579f33a1a1511 SHA512 3568a49e3fdcb2fa47688fce4d818cb01545d854890806e4508f228b18b712cbb5641a6e173927990e81c9086bdb49f5b4ffd870e5f0345f26de1b4e799eb0d7
DIST diffpdf-2.1.3.tar.gz 91856 BLAKE2B a94b710674508a5b77ca1e18b48e906568b49ecf10ce5f96d425fceb91746922fdf454ee20ec77913cf3d7467e559e59257e7415bf96c44b9c136e1708d4e73f SHA512 137e00f7c1d696b097f271c51fa5f19d471efb85fb3d5381c096c32f1ff824083b1122bbefa758fb9320ac8e0c9c16e6b88c8b6286bd98388d88c45c714a948d
-EBUILD diffpdf-2.1.3.ebuild 678 BLAKE2B b02353d8a5f25b2500f04c63c8f810e5cd1c5ea0cca37f27b3df579016a976b28f28e499f4e7229e2b0dff6ca732d04b96c139e364f4f0307083d2ab6a848af5 SHA512 36af124c32eb8a4255dd137e83ae5c05253ba706088d8144f0e38d1146db1b40ec4653dbddbf6d5c41407208550b8193960e91954d8eceb52fae2dd4eb3ee476
+EBUILD diffpdf-2.1.3-r1.ebuild 801 BLAKE2B 7b1e48d31371bb35da8e84e3cdc2e8d88449e3a772f1f12171bc93e61a936ec49d3ef854d6022b49a295b4b1cb79c5d75e338300e91ba0735e73918c622d67cb SHA512 ed8a68efb77814f627f4ab85d195697814942ab2976e6f415ac3481db967921bd5919515175b0072c4630ff87272d1dda0729bacada1ee05ee03619aaa8ce400
MISC metadata.xml 247 BLAKE2B 317f906045f70ecc77ab85491b683c74618c027d768a499226ea0c46d214b783ff308f6bcb79c1edfaf3c4a01821afd529786bf5ad2cf73e0570aac56177d36e SHA512 4ae39ceedf573357554a383ccfab1d716abb7265c3a1eb407d1dc4bf3b38fc91b5cdeec8ba0bad84efb2595aebb6d115ade1575e12812079e47797b7dcd3fa7a
diff --git a/app-text/diffpdf/diffpdf-2.1.3-r1.ebuild b/app-text/diffpdf/diffpdf-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..1de17d540dfc
--- /dev/null
+++ b/app-text/diffpdf/diffpdf-2.1.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop qmake-utils
+
+DESCRIPTION="Program that textually or visually compares two PDF files"
+HOMEPAGE="http://www.qtrac.eu/diffpdf.html"
+SRC_URI="http://www.qtrac.eu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler:=[qt5]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+PATCHES=( "${FILESDIR}"/${P}-qt5.patch )
+
+src_configure() {
+ $(qt5_get_bindir)/lrelease diffpdf.pro || die "Generating translations failed"
+ eqmake5 PREFIX="${EPREFIX}/usr" diffpdf.pro
+}
+
+src_install() {
+ einstalldocs
+ dobin diffpdf
+ doman diffpdf.1
+ domenu "${FILESDIR}"/${PN}.desktop
+ newicon images/icon.png ${PN}.png
+}
diff --git a/app-text/diffpdf/diffpdf-2.1.3.ebuild b/app-text/diffpdf/diffpdf-2.1.3.ebuild
deleted file mode 100644
index 51e213918991..000000000000
--- a/app-text/diffpdf/diffpdf-2.1.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit qt4-r2 eutils qmake-utils
-
-DESCRIPTION="Program that textually or visually compares two PDF files"
-HOMEPAGE="http://www.qtrac.eu/diffpdf.html"
-SRC_URI="http://www.qtrac.eu/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE=""
-
-DEPEND="
- app-text/poppler:=[qt4]
- >=dev-qt/qtcore-4.6:4
- >=dev-qt/qtgui-4.6:4
-"
-RDEPEND="${DEPEND}"
-
-DOCS="README"
-
-src_configure() {
- $(qt4_get_bindir)/lrelease diffpdf.pro || die 'Generating translations failed'
- qt4-r2_src_configure
-}
-
-src_install() {
- qt4-r2_src_install
-
- dobin diffpdf
- doman diffpdf.1
-}
diff --git a/app-text/diffpdf/files/diffpdf-2.1.3-qt5.patch b/app-text/diffpdf/files/diffpdf-2.1.3-qt5.patch
new file mode 100644
index 000000000000..a7821388aa87
--- /dev/null
+++ b/app-text/diffpdf/files/diffpdf-2.1.3-qt5.patch
@@ -0,0 +1,173 @@
+Description: Build with Qt5
+ Enough changes to make things build with Qt5
+Author: Sune Vuorela <sune@debian.org>
+
+---
+The information above should follow the Patch Tagging Guidelines, please
+checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
+are templates for supplementary fields that you might want to add:
+
+Origin: <vendor|upstream|other>, <url of original patch>
+Bug: <url in upstream bugtracker>
+Bug-Debian: https://bugs.debian.org/<bugnumber>
+Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
+Forwarded: <no|not-needed|url proving that it has been forwarded>
+Reviewed-By: <name and email of someone who approved the patch>
+Last-Update: 2017-11-25
+
+--- diffpdf-2.1.3.orig/aboutform.cpp
++++ diffpdf-2.1.3/aboutform.cpp
+@@ -11,7 +11,6 @@
+ */
+
+ #include "aboutform.hpp"
+-#include <poppler-version.h>
+ #include <QApplication>
+ #include <QHBoxLayout>
+ #include <QSettings>
+@@ -52,7 +51,7 @@ AboutForm::AboutForm(QWidget *parent) :
+ "</ul>"
+ "I also provide training and consultancy in C++, Go, Python&nbsp;2, "
+ "Python&nbsp;3, C++/Qt, and PyQt4.").arg(qApp->applicationName())
+- .arg(Version).arg(qVersion()).arg(POPPLER_VERSION));
++ .arg(Version).arg(qVersion()).arg("Qt 5"));
+ QTextBrowser *contributorsBrowser = new QTextBrowser;
+ contributorsBrowser->setReadOnly(true);
+ contributorsBrowser->setHtml(tr("<table>"
+--- diffpdf-2.1.3.orig/diffpdf.pro
++++ diffpdf-2.1.3/diffpdf.pro
+@@ -31,35 +31,39 @@ TRANSLATIONS += diffpdf_fr.ts
+ TRANSLATIONS += diffpdf_de.ts
+ TRANSLATIONS += diffpdf_es.ts
+ CODECFORTR = UTF-8
+-LIBS += -lpoppler-qt4
++LIBS += -lpoppler-qt5
++ QMAKE_CFLAGS += $$(CPPFLAGS) $$(CFLAGS)
++ QMAKE_CXXFLAGS += $$(CPPFLAGS) $$(CXXFLAGS)
++ QMAKE_LFLAGS += $$(LDFLAGS)
++QT += widgets printsupport
+ win32 {
+ CONFIG += release
+ }
+ exists($(HOME)/opt/poppler024/) {
+ message(Using locally built Poppler library)
+ INCLUDEPATH += $(HOME)/opt/poppler024/include/poppler/cpp
+- INCLUDEPATH += $(HOME)/opt/poppler024/include/poppler/qt4
++ INCLUDEPATH += $(HOME)/opt/poppler024/include/poppler/qt5
+ LIBS += -Wl,-rpath -Wl,$(HOME)/opt/poppler024/lib -L$(HOME)/opt/poppler024/lib
+ } else {
+ exists(/poppler_lib) {
+ message(Using locally built Poppler library on Windows)
+ INCLUDEPATH += /c/poppler_lib/include/poppler/cpp
+- INCLUDEPATH += /c/poppler_lib/include/poppler/qt4
++ INCLUDEPATH += /c/poppler_lib/include/poppler/qt5
+ LIBS += -Wl,-rpath -Wl,/c/poppler_lib/bin -Wl,-L/c/poppler_lib/bin
+ } else {
+- exists(/usr/include/poppler/qt4) {
++ exists(/usr/include/poppler/qt5) {
+ INCLUDEPATH += /usr/include/poppler/cpp
+- INCLUDEPATH += /usr/include/poppler/qt4
++ INCLUDEPATH += /usr/include/poppler/qt5
+ } else {
+ INCLUDEPATH += /usr/local/include/poppler/cpp
+- INCLUDEPATH += /usr/local/include/poppler/qt4
++ INCLUDEPATH += /usr/local/include/poppler/qt5
+ }
+ }
+ }
+ #exists($(HOME)/opt/podofo09/) {
+ # message(Using locally built PoDoFo library)
+ # INCLUDEPATH += $(HOME)/opt/podofo09/include/poppler/cpp
+-# INCLUDEPATH += $(HOME)/opt/podofo09/include/poppler/qt4
++# INCLUDEPATH += $(HOME)/opt/podofo09/include/poppler/qt5
+ # LIBS += -Wl,-rpath -Wl,$(HOME)/opt/podofo09/lib64 -Wl,-L$(HOME)/opt/podofo09/lib64
+ #} else {
+ # exists(/usr/include/podofo) {
+--- diffpdf-2.1.3.orig/generic.hpp
++++ diffpdf-2.1.3/generic.hpp
+@@ -12,7 +12,7 @@
+ for more details.
+ */
+
+-#include <poppler-qt4.h>
++#include <poppler-qt5.h>
+ #include <QMetaType>
+ #include <QPair>
+ #include <QPixmap>
+--- diffpdf-2.1.3.orig/helpform.cpp
++++ diffpdf-2.1.3/helpform.cpp
+@@ -11,7 +11,6 @@
+ */
+
+ #include "helpform.hpp"
+-#include <poppler-version.h>
+ #include <QApplication>
+ #include <QFile>
+ #include <QKeySequence>
+--- diffpdf-2.1.3.orig/label.cpp
++++ diffpdf-2.1.3/label.cpp
+@@ -15,6 +15,7 @@
+ #include <QDragEnterEvent>
+ #include <QDragEnterEvent>
+ #include <QMouseEvent>
++#include <QMimeData>
+
+ Label::Label(QWidget *parent) : QLabel(parent)
+ {
+--- diffpdf-2.1.3.orig/lineedit.cpp
++++ diffpdf-2.1.3/lineedit.cpp
+@@ -14,6 +14,7 @@
+ #include "lineedit.hpp"
+ #include <QDragEnterEvent>
+ #include <QDragEnterEvent>
++#include <QMimeData>
+
+
+ LineEdit::LineEdit(QWidget *parent) : QLineEdit(parent)
+--- diffpdf-2.1.3.orig/main.cpp
++++ diffpdf-2.1.3/main.cpp
+@@ -31,7 +31,6 @@ int main(int argc, char *argv[])
+ app.setOrganizationDomain("qtrac.eu");
+ app.setApplicationName("DiffPDF");
+ app.setWindowIcon(QIcon(":/icon.png"));
+- QTextCodec::setCodecForTr(QTextCodec::codecForName("UTF-8"));
+
+ QTextStream out(stdout);
+ QStringList args = app.arguments().mid(1);
+--- diffpdf-2.1.3.orig/mainwindow.hpp
++++ diffpdf-2.1.3/mainwindow.hpp
+@@ -19,7 +19,7 @@
+ #else
+ #include <tr1/memory>
+ #endif
+-#include <poppler-qt4.h>
++#include <poppler-qt5.h>
+ #include <QBrush>
+ #include <QList>
+ #include <QMainWindow>
+--- diffpdf-2.1.3.orig/optionsform.cpp
++++ diffpdf-2.1.3/optionsform.cpp
+@@ -76,9 +76,9 @@ void OptionsForm::createWidgets()
+ << qMakePair(tr("Diagonal \\"), Qt::FDiagPattern)
+ << qMakePair(tr("Diagonal Cross"), Qt::DiagCrossPattern))
+ brushStyleComboBox->addItem(brushSwatch(pair.second, color),
+- pair.first, pair.second);
++ pair.first, QVariant::fromValue(pair.second));
+ brushStyleComboBox->setCurrentIndex(brushStyleComboBox->findData(
+- brush.style()));
++ QVariant::fromValue(brush.style())));
+
+ penStyleComboBox = new QComboBox;
+ typedef QPair<QString, Qt::PenStyle> PenPair;
+@@ -90,9 +90,9 @@ void OptionsForm::createWidgets()
+ << qMakePair(tr("Dash-Dotted"), Qt::DashDotLine)
+ << qMakePair(tr("Dash-Dot-Dotted"), Qt::DashDotDotLine))
+ penStyleComboBox->addItem(penStyleSwatch(pair.second, color),
+- pair.first, pair.second);
++ pair.first, QVariant::fromValue(pair.second));
+ penStyleComboBox->setCurrentIndex(penStyleComboBox->findData(
+- pen.style()));
++ QVariant::fromValue(pen.style())));
+
+ alphaSpinBox = new QSpinBox;
+ alphaSpinBox->setRange(1, 100);
diff --git a/app-text/diffpdf/files/diffpdf.desktop b/app-text/diffpdf/files/diffpdf.desktop
new file mode 100644
index 000000000000..1f4d0cb0d090
--- /dev/null
+++ b/app-text/diffpdf/files/diffpdf.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=DiffPDF
+Comment=Compare two PDF files
+Exec=diffpdf
+Icon=diffpdf
+Terminal=false
+Type=Application
+Categories=Utility;Qt;