summaryrefslogtreecommitdiff
path: root/app-text/editorconfig-core-c
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
commit6957f5c65b02bba533954eabc0b62f5de36be206 (patch)
tree21d8ab8f61dffd9cccc82d0badb68982516a6855 /app-text/editorconfig-core-c
parente91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (diff)
gentoo resync : 10.04.2018
Diffstat (limited to 'app-text/editorconfig-core-c')
-rw-r--r--app-text/editorconfig-core-c/Manifest2
-rw-r--r--app-text/editorconfig-core-c/editorconfig-core-c-0.12.2.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/app-text/editorconfig-core-c/Manifest b/app-text/editorconfig-core-c/Manifest
index 0bab058c82dc..0322a4b4e195 100644
--- a/app-text/editorconfig-core-c/Manifest
+++ b/app-text/editorconfig-core-c/Manifest
@@ -1,3 +1,5 @@
DIST editorconfig-core-c-0.12.1.tar.gz 65369 BLAKE2B 30296b64bd215a8b51d3b4d6146ce5eac13cb1a8ba8a25d0faabcc22989503d9d73bc138240b475eb7ea4eecd5f5bbbf347519b1696373daf55ffd27fc772f4c SHA512 3517f7db84d632615ba651eeafab6730739b7bf01f4ea34fbca65f58463fbbcbabc101587b289a7922b55708453262c65569077c51087424d47d0676dc1db686
+DIST editorconfig-core-c-0.12.2.tar.gz 67002 BLAKE2B 6b808366acc8d0a96fc47cb74d620a4028978d7114b4a64d6799527276442f1d39ba8d5611530f873c78b7c49893c5edecec84dcc6f2616ba2663cb36fa92d0d SHA512 6ab3e4f7f95c83c0781064ca15bb70394bb947f9d4cd1348224f02e25c65021d14439b913775d7cfafb93476158799c34438fa548adf3c7ec6dbfd6f1052a046
EBUILD editorconfig-core-c-0.12.1.ebuild 891 BLAKE2B 52eb0995e90c239264a5157438552a958c0ca00d5211e4991c04811e78a2b5fa20a803293c42d4c8c8c24f652b692a07a3b10d8cee363744bd82d4a4ee38ab10 SHA512 527ce58ed36cca79ab12695cbbc05d7e9f5b5761932bf1cea6ad24e1d7117edc4df6ae79af0549d99b2f833877b33d7c66424ff5748db878cf9a6ba634246fcf
+EBUILD editorconfig-core-c-0.12.2.ebuild 907 BLAKE2B 5d210b84b242c0ef32d601bb34674a0583aa9e8fbc0fddb39b41dca08a2e80a5c62d92b86761ce63f49cdda6aaa8803a607a9404c4ab7fa83b4829433596f7a2 SHA512 eec1a6c04c3ae5c18fb54d37765ab947dc99c6e113c8a81bf3036bbb2209cbc07cbf0eb5cef274dcbcc766a39885c9293beb6dc626e63ac273e5af8fee716b59
MISC metadata.xml 388 BLAKE2B d2a5f28be0aea3f3aefd1b8e82e337b87e67192b96bea1e2e0e5073e44f8c54d3f0380a089118d405c417d42ee6d978919dc8e0212a36ee0d3808b706846ad70 SHA512 fbaff22b9f648c2e94d68904cbb23de8ee0340641c626d5a533992837ec6405b65a96872bfdedce3a75351ac73e344d5faed1a51f63a4330f65e4aa8190ffed4
diff --git a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.2.ebuild b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.2.ebuild
new file mode 100644
index 000000000000..1bfe84ca069f
--- /dev/null
+++ b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="EditorConfig core library written in C"
+HOMEPAGE="https://github.com/editorconfig/editorconfig-core-c/"
+SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="cli doc"
+CDEPEND="dev-libs/libpcre:="
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}
+ cli? ( !dev-python/editorconfig-core-py[cli] )"
+
+src_prepare() {
+ sed -e 's:OUTPUT_NAME editorconfig_static:OUTPUT_NAME editorconfig:' \
+ -i src/lib/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=()
+ use doc && mycmakeargs+=(-DINSTALL_HTML_DOC=ON)
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use cli || rm -rf "${ED}usr/bin"
+}