summaryrefslogtreecommitdiff
path: root/app-text/epstool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/epstool
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/epstool')
-rw-r--r--app-text/epstool/Manifest4
-rw-r--r--app-text/epstool/epstool-3.08-r1.ebuild43
-rw-r--r--app-text/epstool/files/gcc43.patch20
-rw-r--r--app-text/epstool/metadata.xml5
4 files changed, 72 insertions, 0 deletions
diff --git a/app-text/epstool/Manifest b/app-text/epstool/Manifest
new file mode 100644
index 000000000000..a8ad1f236da2
--- /dev/null
+++ b/app-text/epstool/Manifest
@@ -0,0 +1,4 @@
+AUX gcc43.patch 632 BLAKE2B 3f4537c7b4e20e50aafa3d8e07379eb8db2e68c1abbe6e096b2e5926b6a3ab539c6478dcff7d03f2c93888abf3dc8c64cd6531c855c9a145fe2c50c9a5a8c144 SHA512 a088a86e2c66469da955a4ba2309142cf54be9d88ca18c8c173d9a285a145c3432ec99d4c212f5f69caeeef17035a063f2ca55d57bf72325258555a0af8ca875
+DIST epstool-3.08.tar.gz 191567 BLAKE2B 6ef2912e10e65809f60444d09facc1ea3800e492e55e87a4f00c95f7dbabd45c4d48b447fd92879e97e9dc2fe9698c1ff7d4cb06bdf3724f16ed89f76a829a8d SHA512 d6d70825c7d08cca318503bd8c12b48408b6d6cd3a64f26df94890373a3e73b68dc09a4eb454b81893c7ee3c11da791cdfed7466eb1410414cd1b97d80e8abf1
+EBUILD epstool-3.08-r1.ebuild 903 BLAKE2B d142c8e851ef544dd098b41572a88afcdc70895a8f61538f70a8dcebce677524e509e51987b242f1ace9ae1ebd125b970819c863a787375d23faf100233f7dda SHA512 ec0b4d0c5282fcbc39c726b21809f4a7bbb41dacda97a94e2574574f2cc32d08fe768430710f7ac1e91f28a98a8492d74b9df7d430ec7da4aef0507aa2210d3b
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/epstool/epstool-3.08-r1.ebuild b/app-text/epstool/epstool-3.08-r1.ebuild
new file mode 100644
index 000000000000..04ef4ccd4060
--- /dev/null
+++ b/app-text/epstool/epstool-3.08-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Creates or extracts preview images in EPS files, fixes bounding boxes"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/gsview/epstool.htm"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/gcc43.patch
+
+ sed -i \
+ -e '/^CC/s/=/?=/' \
+ -e '/^CLINK/s/gcc/$(CC)/' \
+ src/unixcom.mak || die
+ tc-export CC
+
+ epatch_user
+
+ # parallel make issue (bug #506978)
+ mkdir bin || die
+ mkdir epsobj || die
+}
+
+src_compile() {
+ emake epstool
+}
+
+src_install() {
+ dobin bin/epstool
+ doman doc/epstool.1
+ dohtml doc/epstool.htm doc/gsview.css
+}
diff --git a/app-text/epstool/files/gcc43.patch b/app-text/epstool/files/gcc43.patch
new file mode 100644
index 000000000000..b50250a9af1a
--- /dev/null
+++ b/app-text/epstool/files/gcc43.patch
@@ -0,0 +1,20 @@
+--- a/src/epstool.c
++++ b/src/epstool.c
+@@ -2824,7 +2824,7 @@
+ code = -1;
+ }
+ if ((code==0) && stdout_name && (hChildStdoutWr == -1)) {
+- handle = open(stdout_name, O_WRONLY | O_CREAT);
++ handle = open(stdout_name, O_WRONLY | O_CREAT, 0644);
+ hChildStdoutWr = dup2(handle, 1);
+ if (handle != -1)
+ close(handle);
+@@ -2832,7 +2832,7 @@
+ code = -1;
+ }
+ if ((code==0) && stderr_name && (hChildStderrWr == -1)) {
+- handle = open(stderr_name, O_WRONLY | O_CREAT);
++ handle = open(stderr_name, O_WRONLY | O_CREAT, 0644);
+ hChildStderrWr = dup2(handle, 2);
+ if (handle != -1)
+ close(handle);
diff --git a/app-text/epstool/metadata.xml b/app-text/epstool/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-text/epstool/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>