summaryrefslogtreecommitdiff
path: root/app-text/foliate/foliate-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-28 16:53:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-28 16:53:39 +0000
commitb35600c999baee29d87c2748f7207ce79ca87067 (patch)
treec2724e0a74f5c08fb608a856be4b111e2a380c2d /app-text/foliate/foliate-3.0.1.ebuild
parent3e690338421a6b64f6f44aa03db7416d75e0633a (diff)
gentoo auto-resync : 28:11:2023 - 16:53:39
Diffstat (limited to 'app-text/foliate/foliate-3.0.1.ebuild')
-rw-r--r--app-text/foliate/foliate-3.0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/foliate/foliate-3.0.1.ebuild b/app-text/foliate/foliate-3.0.1.ebuild
new file mode 100644
index 000000000000..675697e18bee
--- /dev/null
+++ b/app-text/foliate/foliate-3.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="ar cs de el es eu fa_IR fr he hi id ie it ko nb nl nn pt_BR ru sv tr uk zh_CN zh_TW"
+inherit meson plocale xdg gnome2-utils
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
+DESCRIPTION="gtk ebook reader built with gjs"
+HOMEPAGE="https://github.com/johnfactotum/foliate/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="${MESON_DEPEND}"
+RDEPEND=">=dev-libs/gjs-1.76
+ >=gui-libs/gtk-4.12
+ gui-libs/libadwaita
+ net-libs/webkit-gtk:6[introspection]
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ plocale_find_changes "${S}"/po '' '.po'
+
+ rm_po() {
+ rm po/${1}.po
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ plocale_for_each_disabled_locale rm_po
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}