summaryrefslogtreecommitdiff
path: root/app-text/gocr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/gocr
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/gocr')
-rw-r--r--app-text/gocr/Manifest5
-rw-r--r--app-text/gocr/gocr-0.49.ebuild45
-rw-r--r--app-text/gocr/gocr-0.50.ebuild45
-rw-r--r--app-text/gocr/metadata.xml11
4 files changed, 106 insertions, 0 deletions
diff --git a/app-text/gocr/Manifest b/app-text/gocr/Manifest
new file mode 100644
index 000000000000..c578e6fb4122
--- /dev/null
+++ b/app-text/gocr/Manifest
@@ -0,0 +1,5 @@
+DIST gocr-0.49.tar.gz 392386 BLAKE2B 9e2661f33b321b60ca761a259db31fce58be80f2408f003c31cac5a4b4c30d7943b864b36c4c6044c2db2a71efcb6d0b5b22fb17dc33dd971920f6c0210664e6 SHA512 4559ab2cb05d67212da1857a9e7280abea0b4a172454d5145f04f7d23237d065c7b17ea110123ebbea5d62e589c507e73957e1b15e856b19f9bfc5efbecf467c
+DIST gocr-0.50.tar.gz 419209 BLAKE2B 232fe240d7a559cdd4408a3dba3768818aefbd8b2718c7ae40829d69ab79dd68293eb6adfc52e661f2f6cf1290ae9656c84d9d7a8fc20229c0942a8e18fb3b68 SHA512 36392516711d43f8561147684b6f4e22a450bc87f1cb30ceaab4a1821ac583ff5a3d25b3bbf1637f01bfb55366b45cc7d5086d1f29f006d615bb658d0e5faab9
+EBUILD gocr-0.49.ebuild 1194 BLAKE2B 17c24733407f842e9084c57164aa9eb93ebde88b5d2afeff1496bfa66923b5f5e1ad4c11269bffc4b38a922ec87a6f86d8bff942ca57423be6c20f15943b7351 SHA512 d6f044d7a983154b6298c95d8d86bde528c7374d8e6cff82967df4414df07252c81dc691dbb0e49d7ac8c4a5b528b336c4978cbc4ff185bc9e2d675d2733e06a
+EBUILD gocr-0.50.ebuild 1199 BLAKE2B ab0670e4b0c0af277050a2cf59cdcc5aedae968f061943bde4c6aeebfc161336c1e83f397f20cb37a1adabccdaa4fe36f27c9dc0cc90dd2b2ac96ccd96e75a53 SHA512 d73b4c9f4ed68f3c1f09ed7f2fe45d296c0a4fc74a29fb728e40090367be214e030e3615e50c91c9bc156d26ea9403624790ab9d71d3a0dcbf4c046c0f410cfe
+MISC metadata.xml 323 BLAKE2B bb09f6949d6fdefdb0ff856c96a0ab766e9ef11559aed7bc424b6da8eb226f4f9090b708da8b4ab62a123530201bfe721e5e6b505b5a6f3d5cd40f48941a86d9 SHA512 5b38ff42ca62ce001e5041406a24ccd8bc1c7f33d7a9e1f84ca0d5d48a3ad2f80e74732a846ffb6768709748bd2dca5868f76ab4c1b00f1e75a6f622597858e1
diff --git a/app-text/gocr/gocr-0.49.ebuild b/app-text/gocr/gocr-0.49.ebuild
new file mode 100644
index 000000000000..88b3005d5a37
--- /dev/null
+++ b/app-text/gocr/gocr-0.49.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="http://www-e.uni-magdeburg.de/jschulen/ocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc scanner tk"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 app-text/ghostscript-gpl )
+ tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}
+ tk? (
+ media-gfx/xli
+ scanner? ( media-gfx/xsane )
+ )"
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ emake ${mymakes}
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install
+ dodoc AUTHORS BUGS CREDITS HISTORY RE* TODO
+
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${ED}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ dodoc doc/gocr.html doc/examples.txt doc/unicode.txt
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/app-text/gocr/gocr-0.50.ebuild b/app-text/gocr/gocr-0.50.ebuild
new file mode 100644
index 000000000000..d117bc57f841
--- /dev/null
+++ b/app-text/gocr/gocr-0.50.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="http://www-e.uni-magdeburg.de/jschulen/ocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc scanner tk"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 app-text/ghostscript-gpl )
+ tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}
+ tk? (
+ media-gfx/xli
+ scanner? ( media-gfx/xsane )
+ )"
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ emake ${mymakes}
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install
+ dodoc AUTHORS BUGS CREDITS HISTORY RE* TODO
+
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${ED}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ dodoc doc/gocr.html doc/examples.txt doc/unicode.txt
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/app-text/gocr/metadata.xml b/app-text/gocr/metadata.xml
new file mode 100644
index 000000000000..822a31236591
--- /dev/null
+++ b/app-text/gocr/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">jocr</remote-id>
+ </upstream>
+</pkgmetadata>