summaryrefslogtreecommitdiff
path: root/app-text/htag/htag-0.0.24-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/htag/htag-0.0.24-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/htag/htag-0.0.24-r1.ebuild')
-rw-r--r--app-text/htag/htag-0.0.24-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/htag/htag-0.0.24-r1.ebuild b/app-text/htag/htag-0.0.24-r1.ebuild
new file mode 100644
index 000000000000..a326995bb2ee
--- /dev/null
+++ b/app-text/htag/htag-0.0.24-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="random signature maker"
+HOMEPAGE="http://www.earth.li/projectpurple/progs/htag.html"
+SRC_URI="http://www.earth.li/projectpurple/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ~sparc x86"
+IUSE=""
+
+src_install() {
+ newbin htag.pl htag
+ # establish "${D}"usr/share/doc/${PF}, mv 2 folders in 1 line
+ perl-module_src_install
+ mv ./{example-scripts,docs/sample-config/} "${ED}"usr/share/doc/${PF}/ || die
+ dodoc docs/{MACRO_DESCRIPTION,README}
+
+ insinto /usr/share/htag/plugins
+ doins plugins/*
+
+ insinto "${VENDOR_LIB}"
+ doins HtagPlugin/HtagPlugin.pm
+}