summaryrefslogtreecommitdiff
path: root/app-text/html-xml-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-09 01:48:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-09 01:48:35 +0000
commit0b832a429ecd6081aa9faa0eb262303b019d87ea (patch)
treec39bb9eaa7bc30cec17f3a3bdef0cf5ed27c6a75 /app-text/html-xml-utils
parent80e87db4d9ed551615eb2d0309bf370e79500716 (diff)
gentoo auto-resync : 09:03:2025 - 01:48:35
Diffstat (limited to 'app-text/html-xml-utils')
-rw-r--r--app-text/html-xml-utils/Manifest2
-rw-r--r--app-text/html-xml-utils/html-xml-utils-8.7.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-text/html-xml-utils/Manifest b/app-text/html-xml-utils/Manifest
index 639a1d3ad130..3bd6591487b7 100644
--- a/app-text/html-xml-utils/Manifest
+++ b/app-text/html-xml-utils/Manifest
@@ -1,3 +1,5 @@
DIST html-xml-utils-8.6.tar.gz 421530 BLAKE2B 8c13a36798c5bb2e325f0df38696a9428b6c3ca087bbb4d1e7d9f2dd372e0aff386b7747e117016ad733ac07ab56a38b5ad0bcb1a0aa6b5ffd58de0ba2d8027d SHA512 0050b789a4921fa66b863255f1fd1ef9826e4b778ebc6dc67592fe854ec314b13cd8b162af67dae204018867966cfd5cb9822345917d3de3dc76c797bc0d2ec1
+DIST html-xml-utils-8.7.tar.gz 426378 BLAKE2B fe485559138895f49c4451c50367cd77aeb05102610c3d532521f7cee7c045c0cb08fd142b7f28e0eac078d043e15d284291063c3545af812c1d54351d43c398 SHA512 dc3896c6d5b15cf7363ebdc1cb373f762d99f7eb7c37d5f36669b3c8e026a840d2045adef65a4e6067315f2cf8fc97961fa1f63f309525eb2665ef8b69df4be3
EBUILD html-xml-utils-8.6.ebuild 715 BLAKE2B 03c4db027e7e42651fc8496915d7ff3a856d41ad8d070d8b1a62a0ed372653799e2dbf4a071922571291afd0a07bd7f160e871922ee2f744fe1355e6195a49e7 SHA512 84c3adc5acdb3f85f7bc760a4977f39cbcfe4b51b8d8d2c4bf807ba13c10f296bc4532b0a2fc8c364348df8b3653df4cf8eb6027ef084e72cc8e7204880388de
+EBUILD html-xml-utils-8.7.ebuild 768 BLAKE2B 366014d9a5094077690f9db4b8fe9edaea9e7fd5927b78320fe76d45f7800d5d58a6e0f6cd7ef3f36026206809a26e07ad64a2e221b96d0a221e9b8148178fd6 SHA512 c4b0b00c69d60cf077043bceb87269c0fbce5477d82c8c068e56c0c584eea984cb8b2357e0e6e04a29eca585382e16c36ac3f25c90059165597e8a0d907f0905
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-text/html-xml-utils/html-xml-utils-8.7.ebuild b/app-text/html-xml-utils/html-xml-utils-8.7.ebuild
new file mode 100644
index 000000000000..24e4663711cc
--- /dev/null
+++ b/app-text/html-xml-utils/html-xml-utils-8.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A number of simple utilities for manipulating HTML and XML files"
+HOMEPAGE="https://www.w3.org/Tools/HTML-XML-utils/"
+SRC_URI="https://www.w3.org/Tools/HTML-XML-utils/${P}.tar.gz"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ net-dns/libidn2:=
+ net-misc/curl
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -e "/doc_DATA = COPYING/d" -i Makefile.in || die
+}
+
+src_test() {
+ # Lots of tests lack a shebang and use bashisms
+ # (seems to be better wrt bashisms as of 8.6, but still no shebang. recheck?)
+ # (as of 8.7 4 tests fail with app-shells/dash)
+ emake check SHELL="${BROOT}"/bin/bash
+}