summaryrefslogtreecommitdiff
path: root/app-text/html2text/html2text-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-text/html2text/html2text-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-text/html2text/html2text-9999.ebuild')
-rw-r--r--app-text/html2text/html2text-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/html2text/html2text-9999.ebuild b/app-text/html2text/html2text-9999.ebuild
new file mode 100644
index 000000000000..3093b0ab8ec4
--- /dev/null
+++ b/app-text/html2text/html2text-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/grobian/html2text.git"
+else
+ SRC_URI=""
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+DESCRIPTION="HTML to text converter"
+HOMEPAGE="https://github.com/grobian/html2text"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_prepare() {
+ default
+ tc-export CXX
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" DEBUG="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin html2text
+ doman html2text.1 html2textrc.5
+ dodoc CHANGES CREDITS KNOWN_BUGS TODO
+}