summaryrefslogtreecommitdiff
path: root/app-text/htmlinc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/htmlinc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/htmlinc')
-rw-r--r--app-text/htmlinc/Manifest5
-rw-r--r--app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch129
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild37
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1.ebuild31
-rw-r--r--app-text/htmlinc/metadata.xml5
5 files changed, 207 insertions, 0 deletions
diff --git a/app-text/htmlinc/Manifest b/app-text/htmlinc/Manifest
new file mode 100644
index 000000000000..fe31c1db50ea
--- /dev/null
+++ b/app-text/htmlinc/Manifest
@@ -0,0 +1,5 @@
+AUX htmlinc-gcc3-gentoo.patch 3601 BLAKE2B d268406b773c21cd2885d3f9b5e66ad0121493152a454811b5af1bb20e8ee857777374f2424d68ae9634c74d30d6e24a8d09779059c8fe4440db390259108e23 SHA512 f29d5c823fae27ef027002a8e075e105f028c8a4892d142c64d69af7bca52a63de4ca19aa0cf86acc67f772349472d2b04003c71257cf1b7464c9dee56d95afd
+DIST htmlinc.tar.gz 17042 BLAKE2B 07c9333599876c17846dec8d40c0eba31f1f9321cfa463e4c5dd2698a120c878c6b2d0e6593eb78d22a15fa5333e0fb26ed064a9cccf6b95641cd9a7e3a13a53 SHA512 2bdb7a5df4a8152d9a23f7b740995bd565e92998ef199cfb7d08b1f5e8ae4390c5179f78da71dfa4b7ce18a2a0bfe6002d465b0fa8d860a25afdec5eb4f3ee4c
+EBUILD htmlinc-1.0_beta1-r2.ebuild 722 BLAKE2B f41a4bfbc8f66da2208c4c3a85fdbb0e64b399688cfc43980f2dd7ac0eec1fb932a999674c25dc4938a797d4ead42cf5f875b39726cc8b01b0120a295c12b70d SHA512 f2514266fa029136b0ea9561033624aafd61a89ff51e9d512bb2046663495e2ee281d4390826f724184527c48e4a571a3a5c700c103b987f2a6f460edb68f60e
+EBUILD htmlinc-1.0_beta1.ebuild 528 BLAKE2B 34f15f9f94bfa769fbf258cc81b2878acc4c0c9c29b71de890291127c73b8cb1ae7e95973be9a6a46987b0c91aeab948829588afe17b6b1ee28e1bb76ca8684e SHA512 5cfd9473e10c5b0676c59376070438f8c2c21f5e8a9659ce19ac9ab951575262664f7a1fe3754743afe8f171b0dd7a03c1cd3f75e9eaa55a13edd8be47ed2d03
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch b/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch
new file mode 100644
index 000000000000..eb92c07ff51b
--- /dev/null
+++ b/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch
@@ -0,0 +1,129 @@
+diff -u htmlinc/bytevector.cc htmlinc-1/bytevector.cc
+--- htmlinc/bytevector.cc 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/bytevector.cc 2002-09-11 13:55:25.000000000 +0200
+@@ -119,7 +119,7 @@
+ }
+
+ bool Bytevector::freadln(int file,char seperator){
+- vector<Bytevector*> v;
++ std::vector<Bytevector*> v;
+ Bytevector *b;
+ int index=0;
+ int status;
+@@ -152,7 +152,7 @@
+
+
+ void Bytevector::freadeof(int file){
+- vector<Bytevector*> v;
++ std::vector<Bytevector*> v;
+ Bytevector *b;
+ int index=0;
+ int status;
+diff -u htmlinc/bytevector.h htmlinc-1/bytevector.h
+--- htmlinc/bytevector.h 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/bytevector.h 2002-09-11 13:54:50.000000000 +0200
+@@ -54,7 +54,7 @@
+
+
+
+-class VectorIndexList : public vector<int> {
++class VectorIndexList : public std::vector<int> {
+ };
+
+
+diff -u htmlinc/stringlist.cc htmlinc-1/stringlist.cc
+--- htmlinc/stringlist.cc 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/stringlist.cc 2002-09-11 13:57:47.000000000 +0200
+@@ -283,7 +283,7 @@
+ for (Stringlist::iterator i=begin(); i!=end(); i++){
+ delete *i;
+ }
+- vector<Bytevector *>::clear();
++ std::vector<Bytevector *>::clear();
+ }
+
+
+@@ -373,7 +373,7 @@
+
+ void Stringlist::insert(Bytevector *b, int pos){
+ iterator i=begin()+pos;
+- vector<Bytevector *>::insert(i,b);
++ std::vector<Bytevector *>::insert(i,b);
+ }
+
+ void Stringlist::insert(Bytevector &b, int pos){
+@@ -417,7 +417,7 @@
+
+
+ Bytevector& Stringlist::operator[](int i){
+- return *(vector<Bytevector *>::operator[](i));
++ return *(std::vector<Bytevector *>::operator[](i));
+ }
+
+
+diff -u htmlinc/stringlist.h htmlinc-1/stringlist.h
+--- htmlinc/stringlist.h 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/stringlist.h 2002-09-11 13:56:32.000000000 +0200
+@@ -57,12 +57,12 @@
+ }
+ };
+
+-class MatrixIndexList: public vector<MatrixIndex> {
++class MatrixIndexList: public std::vector<MatrixIndex> {
+ };
+
+
+
+-class Stringlist : public vector<Bytevector*> {
++class Stringlist : public std::vector<Bytevector*> {
+ private:
+ Stringlist::iterator getID(Bytevector id);
+
+diff -Naur htmlinc-old/help.h htmlinc/help.h
+--- htmlinc/help.h 2000-08-08 09:04:28.000000000 -0400
++++ htmlinc-1/help.h 2004-03-01 19:43:43.770233421 -0500
+@@ -4,25 +4,25 @@
+
+ char * helpV[]=
+ {
+-{"HTML INCLUDE SYSTEM Version 1.0 beta1 - Compatible to Phase 5"},
+-{"Copyright (C) 2000 , Ulli Meybohm, www.meybohm.de (GNU General Public License)"},
+-{""},
+-{"Start: "},
+-{" htmlinc <include_dir> <htmlfile_1> <htmlfile_2> ... <htmlfile_n>"},
+-{""},
+-{"Options:"},
+-{" <include_dir> = Directory of the Includefiles"},
+-{" <htmlfile_i> = HTML-Files in which the includes should be updated"},
+-{""},
+-{"Examples:"},
+-{" 1: htmlinc ~/www/inc/ *.html"},
+-{""},
+-{" 2: cd ~/www"},
+-{" htmlinc inc/ `find * | grep \"\\\\.\"html` (recursive)"},
+-{" "},
+-{""},
+-{"Report bugs to ulli@meybohm.de."},
+-{""}
++"HTML INCLUDE SYSTEM Version 1.0 beta1 - Compatible to Phase 5",
++"Copyright (C) 2000 , Ulli Meybohm, www.meybohm.de (GNU General Public License)",
++"",
++"Start: ",
++" htmlinc <include_dir> <htmlfile_1> <htmlfile_2> ... <htmlfile_n>",
++"",
++"Options:",
++" <include_dir> = Directory of the Includefiles",
++" <htmlfile_i> = HTML-Files in which the includes should be updated",
++"",
++"Examples:",
++" 1: htmlinc ~/www/inc/ *.html",
++"",
++" 2: cd ~/www",
++" htmlinc inc/ `find * | grep \"\\\\.\"html` (recursive)",
++" ",
++"",
++"Report bugs to ulli@meybohm.de.",
++""
+ };
+
+ int helpC=18;
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
new file mode 100644
index 000000000000..3a6d05570bbb
--- /dev/null
+++ b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="HTML Include System by Ulli Meybohm"
+HOMEPAGE="http://www.meybohm.de/"
+SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}/htmlinc
+
+src_prepare() {
+ epatch "${FILESDIR}"/htmlinc-gcc3-gentoo.patch
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ # This is C++ not C source
+ emake \
+ CC=$(tc-getCXX) \
+ CFLAGS="${CXXFLAGS} -Wall" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin htmlinc
+ dodoc README
+}
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
new file mode 100644
index 000000000000..a11b46cd4146
--- /dev/null
+++ b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils
+
+DESCRIPTION="HTML Include System by Ulli Meybohm"
+HOMEPAGE="http://www.meybohm.de/"
+SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+S=${WORKDIR}/htmlinc
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/htmlinc-gcc3-gentoo.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CXXFLAGS} -Wall" || die
+}
+
+src_install() {
+ dobin htmlinc
+}
diff --git a/app-text/htmlinc/metadata.xml b/app-text/htmlinc/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-text/htmlinc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>