summaryrefslogtreecommitdiff
path: root/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-text/htmlmin/htmlmin-0.1.12-r1.ebuild')
-rw-r--r--app-text/htmlmin/htmlmin-0.1.12-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild b/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
new file mode 100644
index 000000000000..6bc38c00903f
--- /dev/null
+++ b/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+# upstream doesn't do tags much
+EGIT_COMMIT=220b1d16442eb4b6fafed338ee3b61f698a01e63
+DESCRIPTION="A configurable HTML Minifier with safety features"
+HOMEPAGE="https://github.com/mankyd/htmlmin"
+SRC_URI="
+ https://github.com/mankyd/htmlmin/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ sed '/prune/d' -i MANIFEST.in || die
+ distutils-r1_src_prepare
+}