summaryrefslogtreecommitdiff
path: root/app-text/hyperestraier/files/hyperestraier-perl.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/hyperestraier/files/hyperestraier-perl.patch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/hyperestraier/files/hyperestraier-perl.patch')
-rw-r--r--app-text/hyperestraier/files/hyperestraier-perl.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-text/hyperestraier/files/hyperestraier-perl.patch b/app-text/hyperestraier/files/hyperestraier-perl.patch
new file mode 100644
index 000000000000..dbafd483d926
--- /dev/null
+++ b/app-text/hyperestraier/files/hyperestraier-perl.patch
@@ -0,0 +1,24 @@
+--- a/perlnative/Makefile.in
++++ b/perlnative/Makefile.in
+@@ -29,10 +29,10 @@
+ # Building binaries
+ PERL = @PERL@
+ POD2HTML = @POD2HTML@
+-CC = gcc
++CC = @CC@
+ INC = -I. -I../.. -I$(MYHEADDIR) -I$(HOME)/include -I/usr/local/include
+ OPTIMIZE = @MYOPTIMIZE@
+-LD = gcc
++LD = @CC@
+ LIBS = -L../.. -L$(MYLIBDIR) -L$(HOME)/lib -L/usr/local/lib @LIBS@
+ RUNENV = LD_LIBRARY_PATH=.:..:/lib:/usr/lib:$(MYLIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@
+
+@@ -46,7 +46,7 @@
+ all :
+ ( cd src && if ! [ -f Makefile ] ; \
+ then $(RUNENV) $(PERL) Makefile.PL CC="$(CC)" INC="$(INC)" OPTIMIZE="$(OPTIMIZE)" \
+- LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" ; fi )
++ LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" INSTALLDIRS="vendor" ; fi )
+ ( cd src && make )
+ @printf '\n'
+ @printf '#================================================================\n'