summaryrefslogtreecommitdiff
path: root/app-text/iso-codes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-text/iso-codes
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/Manifest2
-rw-r--r--app-text/iso-codes/iso-codes-4.4.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 7467a8816244..45100bbf8d23 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1,3 +1,5 @@
DIST iso-codes-3.76.tar.xz 3474728 BLAKE2B b418b7b80d1926e765b65aad4edbd74ad8d37251fda14e3ab0e222095762d54e358de6f8d4a08fde8ae14460fd975a2a541ca6a5a4cf8ef1d777719462b0f991 SHA512 a0f6714a79a52b5dab82a268e85cb2d019ff5255744b88d088dcd7d5a15eb9710876a338a0a5d0f5659b4146bc6cc53d6d3474d621b3dcca7c47afabfc7e0dfa
+DIST iso-codes-4.4.tar.gz 13299605 BLAKE2B 485f3b0240f1892fb96f2b5c391b3f0adc593fac97d53748aa104208936d1bf81de1d40e742ab48e3663cea0ce5b28a20782df2f4eed251bab5b8a7055745d0e SHA512 d22ecdef75cd07b59ea0dbc87d25eb254676ab83297c1a43dbad9d3471ba355630f5588b4590972526f9e885b2e1ec307303ac0bb94b2dd5c707377c1cfa64d8
EBUILD iso-codes-3.76.ebuild 2411 BLAKE2B 2ea8d7891bb7d0dd56f4eb7931c5bff65412da737701001a8051730078a7d5bf5ad60cb53eb42ce93602198e0af26e9752da34e6801b86d777ad003bd9042640 SHA512 90c20515ee2d490550ac53a29b63cbe63d941edfc0486ceb8b383d7a064abfce0bfcebdeb78c6955ceba112ff9733c59be35f68686581cd2847a0371e8d07407
+EBUILD iso-codes-4.4.ebuild 2610 BLAKE2B 848c31fc51e13012b69624f64b5d87f0dfce311c230f88e256fefcb03bf8fd0065c82894af1d8a86cbeef6b46270d0d5c8a0884017c00d40805a1c5a0aa2ef7a SHA512 34be1311ad85ee8e956a70080a9d94f31ad4735f045748d438a18224756b2830348efc390c4b1415e0df21a363a6d779a64408c9c07f75504a8673aedc50e450
MISC metadata.xml 480 BLAKE2B 3aefef945cb111095839e8fa8b84757e7f51a9aa8848806911d8c01763ab2d2f1d0c5b31c042f6ee307756e007893f6559c54d74a104caa612c9a6d39b2eea7e SHA512 5729ca31911ea7dad748e9f3afdd1f45f9034d783b56a75609101bfdb0a204bda8a078e7d251e89731091726062c4ac962e000ec7a898cb66ff787c8f2308d4c
diff --git a/app-text/iso-codes/iso-codes-4.4.ebuild b/app-text/iso-codes/iso-codes-4.4.ebuild
new file mode 100644
index 000000000000..5494c38bf591
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kn ko kok ku kv kw ky lo lt lv mai mhr mi mk ml mn mo mr ms mt my na nah nb nb_NO ne nl nn nso nv oc or pa pap pi pl ps pt pt_BR ro ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/${P}/${PN}-${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+S="${WORKDIR}/${PN}-${P}"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+# l10n_find_plocales_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}