summaryrefslogtreecommitdiff
path: root/app-text/landslide
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/landslide
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/landslide')
-rw-r--r--app-text/landslide/Manifest3
-rw-r--r--app-text/landslide/landslide-1.1.3.ebuild31
-rw-r--r--app-text/landslide/metadata.xml10
3 files changed, 44 insertions, 0 deletions
diff --git a/app-text/landslide/Manifest b/app-text/landslide/Manifest
new file mode 100644
index 000000000000..741e25f52065
--- /dev/null
+++ b/app-text/landslide/Manifest
@@ -0,0 +1,3 @@
+DIST landslide-1.1.3.tar.gz 151003 BLAKE2B 471cc83cbfc1c7ddc437b88514fb48632016e0915fc27c65d502a71b94f83a1184de8a7dbfaf2af8b75963e687c1af903add48e5ac8893308d9cfa07fdcc4c61 SHA512 2b29c416f8af04c0bf048060e0fe67b0b6a5e293485c5e3f68b9d1ce9d63ef66ca3bc58a96f65705c6918542932ef0a2fa6072b17c4c01cfc1975d283b417152
+EBUILD landslide-1.1.3.ebuild 819 BLAKE2B ce8070f581d056ca6a7e2b58dd3eaf2681f789b8bfb230594ad3ae4a4334580253d275512a66297ebeb2c62148bc7eaaedeaa2568ab927011db6cc3f90d6bbb9 SHA512 0821de505a6fd2b0e68ae3ac30faff81e71293af4097bc2c952e91a0f9e52dd02b93cbfcb68d116027436c4769422b2fcb5d4d395566f94a2c98973825f8dddb
+MISC metadata.xml 298 BLAKE2B 15316fb3bd0eb0be967bec08510269e31406e72c3cc7623d21cc2334bfb36b8031bf304c4627b085fa64cfec15964cf9a6a486ba29bf312facf1589f36cd9819 SHA512 19a5bf1f42b94a00856b856fc0120024df40a4394a17e61fdacc817d1b355b601595a27cc0f814d3f6b436775799b44aa4f5090daa91452b55d4760e8c89b8d0
diff --git a/app-text/landslide/landslide-1.1.3.ebuild b/app-text/landslide/landslide-1.1.3.ebuild
new file mode 100644
index 000000000000..9d41221f1cf3
--- /dev/null
+++ b/app-text/landslide/landslide-1.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Generates a slideshow using the slides that power the html5-slides presentation"
+HOMEPAGE="https://github.com/adamzap/landslide"
+SRC_URI="https://github.com/adamzap/landslide/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ "
+
+python_install_all() {
+ use examples && EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/app-text/landslide/metadata.xml b/app-text/landslide/metadata.xml
new file mode 100644
index 000000000000..3304ab920105
--- /dev/null
+++ b/app-text/landslide/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>naota@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">adamzap/landslide</remote-id>
+ </upstream>
+</pkgmetadata>