summaryrefslogtreecommitdiff
path: root/app-text/libgepub/libgepub-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/libgepub/libgepub-0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/libgepub/libgepub-0.4.ebuild')
-rw-r--r--app-text/libgepub/libgepub-0.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/libgepub/libgepub-0.4.ebuild b/app-text/libgepub/libgepub-0.4.ebuild
new file mode 100644
index 000000000000..816748d46117
--- /dev/null
+++ b/app-text/libgepub/libgepub-0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="GObject based library for handling and rendering epub documents"
+HOMEPAGE="https://git.gnome.org/browse/libgepub"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+introspection"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}