summaryrefslogtreecommitdiff
path: root/app-text/libspectre
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-15 16:00:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-15 16:00:50 +0100
commit2e4d96d87e04d8b2164f764dee727cd9057cf88d (patch)
treef4c931f649af0ae5c5bda4badece9550b631b3ac /app-text/libspectre
parent24968da221fcb0848cdb4dc82a8d39b7f2ee7861 (diff)
gentoo auto-resync : 15:10:2023 - 16:00:49
Diffstat (limited to 'app-text/libspectre')
-rw-r--r--app-text/libspectre/Manifest2
-rw-r--r--app-text/libspectre/libspectre-0.2.12.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-text/libspectre/Manifest b/app-text/libspectre/Manifest
index 70d44b419dde..465de4c37389 100644
--- a/app-text/libspectre/Manifest
+++ b/app-text/libspectre/Manifest
@@ -1,3 +1,5 @@
DIST libspectre-0.2.11.tar.gz 435887 BLAKE2B 46e289553dafe520c76a779ce64f8f5e320541221d885e5707284dd6d89ace7985a0a658fcf26c5ea750fd2751dd2bab0913333cda563ab5ee29c4132f8c99a5 SHA512 97335bc927006031fad8be55befae44bec33347f058f5b1fcf828a8a8d45a6fae2d51ceae4aaffcfa563c7592fdffe1e5a4993f145d6832ec81019c00ae0e37f
+DIST libspectre-0.2.12.tar.gz 436264 BLAKE2B 932f934e4ef66c4319d60ea88842d01caf3663262f6b67606dfc5750eba7d9e13a1e3e0b15764215e703ff1542c3c09387ee4f572075e828ae2f3680d002821c SHA512 3a4045c1e94e7de23b437393389397dd2448363458023b5aa8e43fa0553a160216f038e157374cefc1d09fa74711ad4899aac1fc353c482bd5fe970d9a97461f
EBUILD libspectre-0.2.11.ebuild 995 BLAKE2B 10ee983cb7d8f7957f3124f43934e1a5655a5af276b2a0f37adbff379a8f53d21c3aa025a04e8a55685df4ab323553824e9cad01adaea870f3929b6554617f45 SHA512 c37d91bfe8382e1dcfcc4cd5b3588dd0ba229b59a2f45d73db156ec67755bfba774d42b567bef285f67bbbf13b76fd481166dad2a97178be515ea8cde83848a3
+EBUILD libspectre-0.2.12.ebuild 1002 BLAKE2B 14d2d21a8391f66acaad313d0834966e8ea3938d1ea5d6a6f66e148b1a357f7e1922887e651b461203d50d86cfb10068c02ed12c54ae3e7e841d23eb7b6e779f SHA512 3edded76f8bc7939980ca12ae758a92a94d826d8a8dcabe7cfb1b86a87ba989b1126d654de3933d57bf9e49051cd3dbc4f66595a79d26b4a9c620ddbee4ab847
MISC metadata.xml 335 BLAKE2B 4cdf398a628e226570b34c239055e98dbff354626c725982394782e610fd49b1ea850097af078ddcc70d68f747d1e72eb3aa5af8edaf4d626c13c7cdbd271e2c SHA512 52a72ccc369879a5e4e17cc09ab2608f9cdae4b7ce4fe4e6014746d6b1ac81fe1e6352137f32ac6419febd311738d2ac78bb48b4b51fc646d3a540cb919516ae
diff --git a/app-text/libspectre/libspectre-0.2.12.ebuild b/app-text/libspectre/libspectre-0.2.12.ebuild
new file mode 100644
index 000000000000..b7dec6b75172
--- /dev/null
+++ b/app-text/libspectre/libspectre-0.2.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for rendering Postscript documents"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libspectre"
+SRC_URI="https://libspectre.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug doc"
+
+RDEPEND=">=app-text/ghostscript-gpl-9.53.0:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[doc] )
+"
+
+# does not actually test anything, see bug 362557
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug asserts)
+ $(use_enable debug checks)
+ --disable-test
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}