summaryrefslogtreecommitdiff
path: root/app-text/libwps/libwps-0.4.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
commit28e3d252dc8ac8a5635206dfefe1cfe05058d1db (patch)
treee75bce604750fb72e53ed3684059e2e5d2094509 /app-text/libwps/libwps-0.4.10.ebuild
parentf625b9919a60a30f1bd860f7d1b2eac183ced593 (diff)
gentoo resync : 12.08.2018
Diffstat (limited to 'app-text/libwps/libwps-0.4.10.ebuild')
-rw-r--r--app-text/libwps/libwps-0.4.10.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/libwps/libwps-0.4.10.ebuild b/app-text/libwps/libwps-0.4.10.ebuild
new file mode 100644
index 000000000000..b9ba610b623c
--- /dev/null
+++ b/app-text/libwps/libwps-0.4.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="https://sourceforge.net/p/libwps/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~x86"
+IUSE="doc debug static-libs tools"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable static-libs static) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}