summaryrefslogtreecommitdiff
path: root/app-text/libwps/libwps-0.4.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-text/libwps/libwps-0.4.12.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-text/libwps/libwps-0.4.12.ebuild')
-rw-r--r--app-text/libwps/libwps-0.4.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/libwps/libwps-0.4.12.ebuild b/app-text/libwps/libwps-0.4.12.ebuild
new file mode 100644
index 000000000000..9499a49c965a
--- /dev/null
+++ b/app-text/libwps/libwps-0.4.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="https://sourceforge.net/p/libwps/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="debug doc tools"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/librevenge
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}