summaryrefslogtreecommitdiff
path: root/app-text/linuxdoc-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /app-text/linuxdoc-tools
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'app-text/linuxdoc-tools')
-rw-r--r--app-text/linuxdoc-tools/Manifest2
-rw-r--r--app-text/linuxdoc-tools/linuxdoc-tools-0.9.73.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/app-text/linuxdoc-tools/Manifest b/app-text/linuxdoc-tools/Manifest
index 721e445382bb..020d6148464f 100644
--- a/app-text/linuxdoc-tools/Manifest
+++ b/app-text/linuxdoc-tools/Manifest
@@ -1,3 +1,5 @@
DIST linuxdoc-tools-0.9.72.tar.gz 614429 BLAKE2B 404b311c0560780bd81f021760d32e47cd6ebe8abc9aa64a181b8ce727dd0edbbd88d286cdfdcc97a51981bd0bd299563d7b1b2945e06f83ff32c7d3e56abb19 SHA512 2d522a99212dab2535786b64e0b404a9bb023d1612d8e57a628de21b5e77b104285713a98591c61a2fb2196e687b34180198ab0dfeda2b44fbbce051e9919408
+DIST linuxdoc-tools-0.9.73.tar.gz 613971 BLAKE2B e2e04aaa44d5e2cea5af266e38b476381f87a02b9704e03ae5943f7714634d5d214350abd5b193f2efe656a264403c679495af5f954870b30d32b8b799ad7206 SHA512 b26896316e259cf4ef170814d410b1e39e58f61db49b03b4b9c1f767f8459d84214e92d9dcc09ad739508fd9c3c5fe4a2264cbb3c693a11362e59fd221655252
EBUILD linuxdoc-tools-0.9.72.ebuild 1777 BLAKE2B b61585eaf79a55b9acc1f4711cbaec19d421db998f091a4fb5827292bb30c5720de9ba5a300ad0cf248b509a8ec4d1a0415a4ee498edb18f49279cf673ff35cb SHA512 40632a82dc9252a4bac966174c4e87f6f1adf075fb2ef125ea07ccc5796b98e74d8823d1afff11f98e042ded4eb5b7da82a8b8c5ab052e4f7d53357b84cbf649
+EBUILD linuxdoc-tools-0.9.73.ebuild 1663 BLAKE2B 8a5e2b42c4add946689d6b9219fcfc402bb338d2819b6bb32413f1e24545efddf3a4eed65e3b1ed84346e249cf6ef5fb104b41d7d880bd6519ee30919f699067 SHA512 ea7075321553e28ddd64e9dbaca32323362c5a4c9499b8fe5528b73a8f30754e69eb2e49a1e1e089bf69f3c803d9eb82fdd181dd928d66792ad5173e95c95913
MISC metadata.xml 911 BLAKE2B a78b50af9faf588a872f75b94f1278ce1ef5e16edb8c6f6c953dcc29b466be53f70a63275e5df54bd46f58d726e80f07b8cd8ae051d93f7c6ee11f0c8e63b8fe SHA512 6afd802552b700006b38a5eee516e5e1f59d0af0dff294bc2807804f8a85823ca2c5a928c0cfe2d5ef74d8c34521ecdd2a54d4ff5a1d322f17d42a6e5e6ad0f4
diff --git a/app-text/linuxdoc-tools/linuxdoc-tools-0.9.73.ebuild b/app-text/linuxdoc-tools/linuxdoc-tools-0.9.73.ebuild
new file mode 100644
index 000000000000..18bccf5a4872
--- /dev/null
+++ b/app-text/linuxdoc-tools/linuxdoc-tools-0.9.73.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# EAPI=6 is blocked by Gentoo bugs 497038, 497052.
+EAPI=5
+
+inherit autotools latex-package perl-functions sgml-catalog toolchain-funcs
+
+DESCRIPTION="A toolset for processing LinuxDoc DTD SGML files"
+HOMEPAGE="https://gitlab.com/agmartin/linuxdoc-tools"
+SRC_URI="https://gitlab.com/agmartin/linuxdoc-tools/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+ MIT SGMLUG"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="
+ || ( app-text/openjade app-text/opensp )
+ app-text/sgml-common
+ dev-lang/perl:=
+ sys-apps/groff
+"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/awk
+ doc? (
+ dev-texlive/texlive-fontsrecommended
+ virtual/latex-base
+ )
+"
+
+src_prepare() {
+ # Pregenerated configure scripts fail.
+ eautoreconf
+}
+
+src_configure() {
+ perl_set_version
+ tc-export CC
+ local myeconfargs=(
+ --disable-docs
+ --with-texdir="${TEXMF}/tex/latex/${PN}"
+ --with-perllibdir="${VENDOR_ARCH}"
+ --with-installed-iso-entities
+ )
+ use doc && myeconfargs+=(--enable-docs="txt pdf html")
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # Prevent access violations from bitmap font files generation.
+ use doc && export VARTEXFONTS="${T}/fonts"
+ default_src_compile
+}
+
+src_install() {
+ # Makefile ignores docdir configuration option.
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}" install
+ dodoc ChangeLog README
+}
+
+sgml-catalog_cat_include "/etc/sgml/linuxdoc.cat" "/usr/share/${PN}/${PN}.catalog"
+
+pkg_postinst() {
+ latex-package_pkg_postinst
+ sgml-catalog_pkg_postinst
+}
+
+pkg_postrm() {
+ latex-package_pkg_postrm
+ sgml-catalog_pkg_postrm
+}