summaryrefslogtreecommitdiff
path: root/app-text/mythes/mythes-1.2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
commit9d0673651c57438d51e18c6b8ca894d0491b2df3 (patch)
treec5b6cd187b8998d2c56d3b279ac425973d4c3a33 /app-text/mythes/mythes-1.2.5.ebuild
parentbe21a4c281fc76681a84dd2f103e850866ce4946 (diff)
gentoo auto-resync : 24:08:2022 - 20:48:33
Diffstat (limited to 'app-text/mythes/mythes-1.2.5.ebuild')
-rw-r--r--app-text/mythes/mythes-1.2.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/mythes/mythes-1.2.5.ebuild b/app-text/mythes/mythes-1.2.5.ebuild
new file mode 100644
index 000000000000..e9e541fbdbd0
--- /dev/null
+++ b/app-text/mythes/mythes-1.2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple thesaurus for LibreOffice"
+HOMEPAGE="https://github.com/hunspell/mythes"
+SRC_URI="https://github.com/hunspell/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="app-text/hunspell:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}