summaryrefslogtreecommitdiff
path: root/app-text/namazu/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/namazu/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/namazu/files')
-rw-r--r--app-text/namazu/files/50namazu-gentoo.el2
-rw-r--r--app-text/namazu/files/namazu-2.0.21-memmove.patch56
-rw-r--r--app-text/namazu/files/namazu-gentoo.patch54
-rw-r--r--app-text/namazu/files/namazu-perl-5.18.patch48
-rw-r--r--app-text/namazu/files/namazu-perl-5.26.patch22
5 files changed, 182 insertions, 0 deletions
diff --git a/app-text/namazu/files/50namazu-gentoo.el b/app-text/namazu/files/50namazu-gentoo.el
new file mode 100644
index 000000000000..e2f6e501241c
--- /dev/null
+++ b/app-text/namazu/files/50namazu-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'namazu "namazu" nil t)
diff --git a/app-text/namazu/files/namazu-2.0.21-memmove.patch b/app-text/namazu/files/namazu-2.0.21-memmove.patch
new file mode 100644
index 000000000000..30ad490e44fa
--- /dev/null
+++ b/app-text/namazu/files/namazu-2.0.21-memmove.patch
@@ -0,0 +1,56 @@
+--- a/nmz/search.c
++++ b/nmz/search.c
+@@ -572,7 +572,7 @@
+ {
+ if (*expr == '*' && expr[strlen(expr) - 1] != '*') {
+ /* If suffix match such as '*bar', enforce it into regex */
+- strcpy(expr, expr + 1);
++ memmove(expr, expr + 1, strlen(expr));
+ escape_meta_characters(expr, BUFSIZE * 2);
+ strncat(expr, "$", BUFSIZE * 2 - strlen(expr) - 1);
+ expr[BUFSIZE * 2 - 1] = '\0';
+@@ -584,7 +584,7 @@
+ expr[BUFSIZE * 2 - 1] = '\0';
+ } else if (*expr == '*' && expr[strlen(expr) - 1] == '*') {
+ /* If internal match such as '*foo*', enforce it into regex */
+- strcpy(expr, expr + 1);
++ memmove(expr, expr + 1, strlen(expr));
+ expr[strlen(expr) - 1] = '\0';
+ escape_meta_characters(expr, BUFSIZE * 2);
+ } else if (*expr == '/' && expr[strlen(expr) - 1] == '/') {
+@@ -592,7 +592,7 @@
+ nmz_debug_printf("do REGEX search\n");
+ /* Genuine regex */
+ /* Remove the both of '/' chars at begging and end of string */
+- strcpy(expr, expr + 1);
++ memmove(expr, expr + 1, strlen(expr));
+ expr[strlen(expr) - 1]= '\0';
+ } else {
+ nmz_debug_printf("disabled REGEX search\n");
+@@ -605,7 +605,7 @@
+ || (*expr == '{' && expr[strlen(expr) - 1] == '}'))
+ {
+ /* Delimiters of field search */
+- strcpy(expr, expr + 1);
++ memmove(expr, expr + 1, strlen(expr));
+ expr[strlen(expr) - 1] = '\0';
+ }
+ escape_meta_characters(expr, BUFSIZE * 2);
+@@ -695,7 +695,7 @@
+ delete_beginning_backslash(char *str)
+ {
+ if (*str == '\\') {
+- strcpy(str, str + 1);
++ memmove(str, str + 1, strlen(str));
+ }
+ }
+
+@@ -935,7 +935,7 @@
+ if ((strlen(str) >= 3 && (*str == '"' && str[strlen(str) - 1] == '"'))
+ || (*str == '{' && str[strlen(str) - 1] == '}'))
+ {
+- strcpy(str, str + 1);
++ memmove(str , str + 1, strlen(str));
+ str[strlen(str) - 1]= '\0';
+ }
+ }
diff --git a/app-text/namazu/files/namazu-gentoo.patch b/app-text/namazu/files/namazu-gentoo.patch
new file mode 100644
index 000000000000..8f0275ba27c5
--- /dev/null
+++ b/app-text/namazu/files/namazu-gentoo.patch
@@ -0,0 +1,54 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -19,9 +19,9 @@
+
+ bin_SCRIPTS = nmz-config
+
+-etcdir = $(pkgdatadir)/etc
+-etc_DATA = AUTHORS ChangeLog ChangeLog.1 CREDITS COPYING INSTALL \
+- INSTALL-ja README README-es README-ja NEWS THANKS TODO \
++etcdir = $(docdir)
++etc_DATA = AUTHORS ChangeLog ChangeLog.1 CREDITS \
++ README README-es README-ja NEWS THANKS TODO \
+ HACKING HACKING-ja
+
+ EXTRA_DIST = $(etc_DATA) maintMakefile namazu.spec namazu.spec.in \
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -2,7 +2,7 @@
+ AUTOMAKE_OPTIONS = 1.4 no-dependencies
+ SUBDIRS = en ja
+
+-cssdir = $(pkgdatadir)/doc
++cssdir = $(htmldir)
+
+ css_DATA = namazu.css
+ EXTRA_DIST = $(css_DATA)
+--- a/doc/en/Makefile.am
++++ b/doc/en/Makefile.am
+@@ -1,4 +1,4 @@
+-htmldir = $(pkgdatadir)/doc/en
++htmldir = @htmldir@/en
+
+ html_DATA = manual.html nmz.html tutorial.html tips.html
+ EXTRA_DIST = $(html_DATA)
+--- a/doc/ja/Makefile.am
++++ b/doc/ja/Makefile.am
+@@ -1,4 +1,4 @@
+-htmldir = $(pkgdatadir)/doc/ja
++htmldir = @htmldir@/ja
+
+ html_DATA = manual.html nmz.html tips.html tutorial.html
+ EXTRA_DIST = $(html_DATA)
+--- a/filter/Makefile.am
++++ b/filter/Makefile.am
+@@ -51,9 +51,3 @@
+
+ ETAGS_ARGS = $(filter_DATA) --lang=perl
+ TAGS_DEPENDENCIES = $(filter_DATA)
+-
+-# To remove Windows specific files installed by Namazu 2.0 and/or 2.0.1
+-# and old gfilter.pl (Namazu 2.0.7 or earlier).
+-install-data-local:
+- rm -f $(filterdir)/ole*.pl
+- rm -f $(filterdir)/gfilter.pl
diff --git a/app-text/namazu/files/namazu-perl-5.18.patch b/app-text/namazu/files/namazu-perl-5.18.patch
new file mode 100644
index 000000000000..8674982312d4
--- /dev/null
+++ b/app-text/namazu/files/namazu-perl-5.18.patch
@@ -0,0 +1,48 @@
+2013-12-15 Tadamasa Teranishi <yw3t-trns@asahi-net.or.jp>
+
+ * scripts/mknmz.in, filter/mhonarc.pl: support random HASH
+ for Perl 5.8.1, 5.18.X.
+
+--- a/filter/mhonarc.pl 2008/05/09 07:52:21 1.23.8.8
++++ b/filter/mhonarc.pl 2013/12/15 04:01:53 1.23.8.9
+@@ -1,10 +1,10 @@
+ #
+ # -*- Perl -*-
+-# $Id: mhonarc.pl,v 1.23.8.8 2008-05-09 07:52:21 opengl2772 Exp $
++# $Id: mhonarc.pl,v 1.23.8.9 2013-12-15 04:01:53 opengl2772 Exp $
+ # Copyright (C) 1997-2000 Satoru Takabayashi ,
+ # 1999 NOKUBI Takatsugu ,
+ # 2002 Earl Hood ,
+-# 2000-2008 Namazu Project All rights reserved.
++# 2000-2013 Namazu Project All rights reserved.
+ # This is free software with ABSOLUTELY NO WARRANTY.
+ #
+ # This program is free software; you can redistribute it and/or modify
+@@ -141,9 +141,8 @@
+
+ # Format MHonArc X comment extracted headers as regular headers
+ my $mha_header = "";
+- my($fld_name, $fld_value);
+- while (($fld_name, $fld_value) = each %$mha_fields) {
+- $mha_header .= join('', $fld_name, ': ', $fld_value, "\n");
++ for my $key (sort keys %$mha_fields) {
++ $mha_header .= join('', $key, ': ', $mha_fields->{$key}, "\n");
+ }
+
+ # Added header back to content string.
+--- a/scripts/mknmz.in 2011/07/23 23:50:59 1.85.4.102
++++ b/scripts/mknmz.in 2013/12/15 04:01:53 1.85.4.103
+@@ -77,13 +77,6 @@
+ sub main {
+ my $start_time = time;
+
+- if ($English::PERL_VERSION == 5.008001) {
+- unless (defined $ENV{PERL_HASH_SEED} && $ENV{PERL_HASH_SEED} eq 0) {
+- print "Run mknmz with the environment variable PERL_HASH_SEED=0\n";
+- exit 1;
+- }
+- }
+-
+ init();
+
+ # At first, loading pl/conf.pl to prevent overriding some variables.
diff --git a/app-text/namazu/files/namazu-perl-5.26.patch b/app-text/namazu/files/namazu-perl-5.26.patch
new file mode 100644
index 000000000000..1b3a4e40bd10
--- /dev/null
+++ b/app-text/namazu/files/namazu-perl-5.26.patch
@@ -0,0 +1,22 @@
+--- a/filter/hnf.pl
++++ b/filter/hnf.pl
+@@ -244,7 +244,7 @@
+ $uri = '?%year%month%hiday#%year%month%day0'; # for hns-1.x
+ }
+ $uri =~ s/%%/\34/g;
+- $uri =~ s/%{?([a-z]+)}?/$param{$1}/g;
++ $uri =~ s/%\{?([a-z]+)}?/$param{$1}/g;
+ $uri =~ s/\34/%/g;
+ $uri = $hnf::diary_uri . $uri;
+ $uri =~ s/%7E/~/i;
+--- a/filter/mp3.pl
++++ b/filter/mp3.pl
+@@ -152,7 +152,7 @@
+ mp3::get_title($$contref, $weighted_str, $fields);
+ mp3::get_author($$contref, $fields);
+ mp3::get_album($$contref, $fields);
+- $$contref =~ s/^\w+:{1,1}?//gm;
++ $$contref =~ s/^\w+:?//gm;
+
+ return;
+ }