summaryrefslogtreecommitdiff
path: root/app-text/namazu/namazu-2.0.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /app-text/namazu/namazu-2.0.21.ebuild
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'app-text/namazu/namazu-2.0.21.ebuild')
-rw-r--r--app-text/namazu/namazu-2.0.21.ebuild58
1 files changed, 38 insertions, 20 deletions
diff --git a/app-text/namazu/namazu-2.0.21.ebuild b/app-text/namazu/namazu-2.0.21.ebuild
index 4609a1dfba2b..92d9023d9ae1 100644
--- a/app-text/namazu/namazu-2.0.21.ebuild
+++ b/app-text/namazu/namazu-2.0.21.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-inherit eutils elisp-common
+inherit autotools elisp-common ltprune
DESCRIPTION="Namazu is a full-text search engine"
HOMEPAGE="http://www.namazu.org/"
@@ -12,9 +12,9 @@ SRC_URI="http://www.namazu.org/stable/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="emacs nls tk l10n_ja"
+IUSE="emacs l10n_ja nls static-libs tk"
-RDEPEND=">=dev-perl/File-MMagic-1.20
+RDEPEND="dev-perl/File-MMagic
emacs? ( virtual/emacs )
l10n_ja? (
app-i18n/nkf
@@ -33,21 +33,34 @@ RDEPEND=">=dev-perl/File-MMagic-1.20
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-perl-5.18.patch
+ "${FILESDIR}"/${PN}-perl-5.26.patch
+ "${FILESDIR}"/${P}-memmove.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-2.0.19-gentoo.patch"
- epatch "${FILESDIR}/${PN}-2.0.21-search.patch"
+ default
+
+ mv configure.{in,ac}
+ mv tk${PN}/configure.{in,ac}
+ eautoreconf
}
src_configure() {
- local myconf
- use tk && myconf="--with-namazu=/usr/bin/namazu
- --with-mknmz=/usr/bin/mknmz
- --with-indexdir=/var/lib/namazu/index"
-
- econf \
- $(use_enable nls) \
- $(use_enable tk tknamazu) \
- ${myconf}
+ local myconf=(
+ $(use_enable nls)
+ $(use_enable static-libs static)
+ $(use_enable tk tk${PN})
+ )
+ use tk && myconf+=(
+ --with-${PN}="${EPREFIX}"/usr/bin/${PN}
+ --with-mknmz="${EPREFIX}"/usr/bin/mknmz
+ --with-indexdir="${EPREFIX}"/var/lib/${PN}/index
+ )
+
+ econf "${myconf[@]}"
}
src_compile() {
@@ -55,22 +68,27 @@ src_compile() {
if use emacs; then
cd lisp
- elisp-compile gnus-nmz-1.el namazu.el
+ rm -f browse*
+ elisp-compile *.el
fi
}
+src_test() {
+ emake -j1 check
+}
+
src_install () {
emake DESTDIR="${D}" install
- dodoc AUTHORS CREDITS ChangeLog* HACKING* NEWS README* THANKS TODO etc/*.png
- dohtml -r doc/*
if use emacs; then
- elisp-install ${PN} lisp/gnus-nmz-1.el* lisp/namazu.el*
+ elisp-install ${PN} lisp/*.el*
elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
docinto lisp
dodoc lisp/ChangeLog*
fi
+
+ prune_libtool_files
}
pkg_postinst() {