summaryrefslogtreecommitdiff
path: root/app-text/nfoview
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/nfoview
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/nfoview')
-rw-r--r--app-text/nfoview/Manifest6
-rw-r--r--app-text/nfoview/metadata.xml15
-rw-r--r--app-text/nfoview/nfoview-1.23.ebuild41
-rw-r--r--app-text/nfoview/nfoview-1.24.ebuild41
-rw-r--r--app-text/nfoview/nfoview-9999.ebuild41
5 files changed, 144 insertions, 0 deletions
diff --git a/app-text/nfoview/Manifest b/app-text/nfoview/Manifest
new file mode 100644
index 000000000000..007442666dd7
--- /dev/null
+++ b/app-text/nfoview/Manifest
@@ -0,0 +1,6 @@
+DIST nfoview-1.23.tar.gz 83337 BLAKE2B d73cd6987bf7929c57e8acf0a24278272ea199bf980756ddb5da9a5eddf7760a8c05f0e48a287ee760d4bf4d2594fb08b43a77cef46d371a746629bf76955e91 SHA512 b94724e130cdf58b911634496c52361d008ebfafab3ac40a76612c4891737d4145596a6badc15fe4228c90c1cd7261e5a892e3e462070ebb55f71332b36345d7
+DIST nfoview-1.24.tar.gz 86037 BLAKE2B 5d565680864f1a73a64d9557e69eda0771dc164f12018ac8964fb1c2225005c1bb881c7b9035c7baed2021838e3a291e52fb5af84cf9c271c046cfddd684270c SHA512 91ad1f9f972b7681655b429c0910475012bd2231e51c6db5659b19fb869779d1de10dadc1d6461fa7d577c051af9b74f1d463543a429e1dca438a4ff17ac2293
+EBUILD nfoview-1.23.ebuild 862 BLAKE2B da322567922a6ac0ec9c9a968d7dc78c4ffed6c3dd1122de7039008f322784339686edeef48fb902e3eabaca3b7427b753e4a30266e064f569bc6fda3dd9b367 SHA512 1babd9f4ed2ef92cdd94872253a0f3fe70cbd205bea360f1f8341d7ec5341adb940b97248ec8fbfeaffe067864a880fbcf8f45211b1022292b1b5b024671cdb1
+EBUILD nfoview-1.24.ebuild 862 BLAKE2B da322567922a6ac0ec9c9a968d7dc78c4ffed6c3dd1122de7039008f322784339686edeef48fb902e3eabaca3b7427b753e4a30266e064f569bc6fda3dd9b367 SHA512 1babd9f4ed2ef92cdd94872253a0f3fe70cbd205bea360f1f8341d7ec5341adb940b97248ec8fbfeaffe067864a880fbcf8f45211b1022292b1b5b024671cdb1
+EBUILD nfoview-9999.ebuild 862 BLAKE2B da322567922a6ac0ec9c9a968d7dc78c4ffed6c3dd1122de7039008f322784339686edeef48fb902e3eabaca3b7427b753e4a30266e064f569bc6fda3dd9b367 SHA512 1babd9f4ed2ef92cdd94872253a0f3fe70cbd205bea360f1f8341d7ec5341adb940b97248ec8fbfeaffe067864a880fbcf8f45211b1022292b1b5b024671cdb1
+MISC metadata.xml 457 BLAKE2B fc1b77e74af5461b5ff1e772f60ef2c222f95860b1afb21828aa39d26342c241658e731d80bb937e694ff1195b0a079fb4134e60207539fa799ffdb6cd601c52 SHA512 65cd8b6021811a13d3a319b930afd8a090c5d15fe232e10d403c3ca8258685f6e118a224bdda7e6cbcff17bf72a409f5213a919554d20525c75efca06b1fcfc1
diff --git a/app-text/nfoview/metadata.xml b/app-text/nfoview/metadata.xml
new file mode 100644
index 000000000000..f49632fab59f
--- /dev/null
+++ b/app-text/nfoview/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>till2.schaefer@uni-dortmund.de</email>
+ <name>Till Schäfer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">otsaloma/nfoview</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/nfoview/nfoview-1.23.ebuild b/app-text/nfoview/nfoview-1.23.ebuild
new file mode 100644
index 000000000000..5b1cf0483c63
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.23.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="https://otsaloma.io/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/app-text/nfoview/nfoview-1.24.ebuild b/app-text/nfoview/nfoview-1.24.ebuild
new file mode 100644
index 000000000000..5b1cf0483c63
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.24.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="https://otsaloma.io/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/app-text/nfoview/nfoview-9999.ebuild b/app-text/nfoview/nfoview-9999.ebuild
new file mode 100644
index 000000000000..5b1cf0483c63
--- /dev/null
+++ b/app-text/nfoview/nfoview-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="https://otsaloma.io/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}