summaryrefslogtreecommitdiff
path: root/app-text/nuspell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 22:41:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 22:41:02 +0100
commitf848d5eacad65f1f52c168d9b0f74dec3e89b203 (patch)
tree6cb7b42d08801e79c25ab04d2e95b467ddd0b9bd /app-text/nuspell
parent9257212a8841f37588d5b5a94a7930db4585a106 (diff)
gentoo auto-resync : 09:09:2022 - 22:41:02
Diffstat (limited to 'app-text/nuspell')
-rw-r--r--app-text/nuspell/Manifest2
-rw-r--r--app-text/nuspell/nuspell-5.1.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index 118e890e6a97..62def40cc5d2 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -1,3 +1,5 @@
DIST nuspell-5.1.0.tar.gz 370368 BLAKE2B 67338fe79ddb98267e0c1efc575e47fc1a8f894cd09b6ada6c6a3f5e89b02fe3a81686b1ff1af73e28fd86437d0f115e04fd5f5aea1954c3da4414f25325ec46 SHA512 08ce776d224c66ba4bdd8cb22943741f30e8e5ba03396bfef1db598321c9b0f8814dacffcb52287b3b669426c7b08e2c1a40323341a9ff9768a7187002e1d77a
+DIST nuspell-5.1.1.tar.gz 370879 BLAKE2B b02126a00f266b0a4a2271a530ee1aeac3c42d8b0474b5e2f12afa401f9ecfdb37e2bb2a759e74e522679e850622d34f86a4d66e4f7d6572285de06803ec75d6 SHA512 c33a52e3603071d3281b7cdcfa42776cd7ecb998292939538e53e364cfff63227cf094cd88ee6072b8a857f5d85c984c359a16b480dd462dac9cfd602cfd6c2c
EBUILD nuspell-5.1.0.ebuild 1152 BLAKE2B cca4bd8e919f8ad347d086038e06bca191138832f1270560de0908747e6c3b41b946550b216d8441c3c466540bbe3bfc5687477f3554ce346abd854a4288ab33 SHA512 64fe145846f29008e58e6dd849a42268f5a7a17dbd7e91a31f891913a3c5f99293f713ef6586431d23b744d7233d025e7d4c4e24110a6eba97e8a29da4ec0048
+EBUILD nuspell-5.1.1.ebuild 1149 BLAKE2B d1028f747d33df3c33c7b81b521f5c013607889778c38704e7822ae2af6be1d9d556a7cfbc5a3d05c42929c3855f8ba0485ee97e06a54d7c071158e9757ab1d7 SHA512 cb94edb4f2d4499f0bf8a232bf7ad39149ef6af5ab1c9c74d1fd0e1fe3d36bb89e53111d35c669194001518b905a9e53f356dfa6df8abeb48e56aaf1328aa89c
MISC metadata.xml 490 BLAKE2B ba276bc01e3f077ef3845e104f0ae93d2985d4f0dd90e36deb4623a82f2dced53c59b98035fac64a6e61b0747e93687ea2233042e248fe80f46b302297d81f7e SHA512 5529ab198114d1aeb0af3a6315074255360fb5e15aea6b0de05fed1032092819cdbf9cf6103fe6bf4cb55df193cae870dc47764ccc9570824477dae08abf3f88
diff --git a/app-text/nuspell/nuspell-5.1.1.ebuild b/app-text/nuspell/nuspell-5.1.1.ebuild
new file mode 100644
index 000000000000..ce8325fe5270
--- /dev/null
+++ b/app-text/nuspell/nuspell-5.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/5" # due to libnuspell.so.5
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/icu-60"
+DEPEND="${RDEPEND}
+ doc? ( app-text/pandoc )
+ test? ( <dev-cpp/catch-3:0 )
+ "
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ rm -R external/Catch2/ || die
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}