summaryrefslogtreecommitdiff
path: root/app-text/odt2txt/odt2txt-0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/odt2txt/odt2txt-0.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/odt2txt/odt2txt-0.4-r1.ebuild')
-rw-r--r--app-text/odt2txt/odt2txt-0.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/odt2txt/odt2txt-0.4-r1.ebuild b/app-text/odt2txt/odt2txt-0.4-r1.ebuild
new file mode 100644
index 000000000000..180584feabd5
--- /dev/null
+++ b/app-text/odt2txt/odt2txt-0.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A simple converter from OpenDocument Text to plain text"
+HOMEPAGE="http://stosberg.net/odt2txt/"
+SRC_URI="http://stosberg.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ~ppc64 sparc x86 ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ !app-office/unoconv
+ sys-libs/zlib
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}
+ sys-apps/groff
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-darwin_iconv.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr
+ doman odt2txt.1
+}