summaryrefslogtreecommitdiff
path: root/app-text/odt2txt/odt2txt-0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
commit6957f5c65b02bba533954eabc0b62f5de36be206 (patch)
tree21d8ab8f61dffd9cccc82d0badb68982516a6855 /app-text/odt2txt/odt2txt-0.5.ebuild
parente91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (diff)
gentoo resync : 10.04.2018
Diffstat (limited to 'app-text/odt2txt/odt2txt-0.5.ebuild')
-rw-r--r--app-text/odt2txt/odt2txt-0.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/odt2txt/odt2txt-0.5.ebuild b/app-text/odt2txt/odt2txt-0.5.ebuild
new file mode 100644
index 000000000000..71f794e3cdf1
--- /dev/null
+++ b/app-text/odt2txt/odt2txt-0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple converter from OpenDocument Text to plain text"
+HOMEPAGE="http://stosberg.net/odt2txt/"
+SRC_URI="https://github.com/dstosberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86 ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ !app-office/unoconv
+ sys-libs/zlib
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}
+ sys-apps/groff
+"
+PATCHES="${FILESDIR}/${P}-darwin_iconv.patch"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr
+ doman odt2txt.1
+}