summaryrefslogtreecommitdiff
path: root/app-text/opensp/opensp-1.5.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-text/opensp/opensp-1.5.2-r3.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/opensp/opensp-1.5.2-r3.ebuild')
-rw-r--r--app-text/opensp/opensp-1.5.2-r3.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/app-text/opensp/opensp-1.5.2-r3.ebuild b/app-text/opensp/opensp-1.5.2-r3.ebuild
deleted file mode 100644
index 655afe2945f7..000000000000
--- a/app-text/opensp/opensp-1.5.2-r3.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils flag-o-matic
-
-MY_P=${P/opensp/OpenSP}
-
-DESCRIPTION="A free, object-oriented toolkit for SGML parsing and entity management"
-HOMEPAGE="http://openjade.sourceforge.net/"
-SRC_URI="mirror://sourceforge/openjade/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc nls static-libs test"
-
-DEPEND="net-libs/libnsl:0=
- nls? ( sys-devel/gettext )
- doc? (
- app-text/xmlto
- app-text/docbook-xml-dtd:4.1.2
- )
- test? (
- app-text/docbook-xml-dtd:4.5
- app-text/openjade
- app-text/sgml-common
- )"
-RDEPEND="net-libs/libnsl:0="
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.5-gcc34.patch \
- "${FILESDIR}"/${P}-fix-segfault.patch
-}
-
-src_configure() {
- export CONFIG_SHELL=${BASH} # configure needs bash
-
- # The following filters are taken from openjade's ebuild. See bug #100828.
- # Please note! Opts are disabled. If you know what you're doing
- # feel free to remove this line. It may cause problems with
- # docbook-sgml-utils among other things.
- #ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
- strip-flags
-
- econf \
- --enable-http \
- --enable-default-catalog="${EPREFIX}"/etc/sgml/catalog \
- --enable-default-search-path="${EPREFIX}"/usr/share/sgml \
- --datadir="${EPREFIX}"/usr/share/sgml/${P} \
- $(use_enable nls) \
- $(use_enable doc doc-build) \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- emake pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}
-}
-
-src_test() {
- # Skipping tests known not to work
- emake SHOWSTOPPERS= check
- SANDBOX_PREDICT="${SANDBOX_PREDICT%:/}"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- pkgdocdir="${EPREFIX}"/usr/share/doc/${PF} \
- install
-
- prune_libtool_files
-
- dodoc AUTHORS BUGS ChangeLog NEWS README
-}