summaryrefslogtreecommitdiff
path: root/app-text/paperwork-backend/paperwork-backend-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/paperwork-backend/paperwork-backend-1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/paperwork-backend/paperwork-backend-1.2.ebuild')
-rw-r--r--app-text/paperwork-backend/paperwork-backend-1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/paperwork-backend/paperwork-backend-1.2.ebuild b/app-text/paperwork-backend/paperwork-backend-1.2.ebuild
new file mode 100644
index 000000000000..da6daad02406
--- /dev/null
+++ b/app-text/paperwork-backend/paperwork-backend-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backend part of Paperwork (Python API, no UI)"
+HOMEPAGE="https://github.com/openpaperwork/paperwork-backend"
+SRC_URI="https://github.com/openpaperwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/poppler[introspection]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/simplebayes[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"