summaryrefslogtreecommitdiff
path: root/app-text/paperwork
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
commit198bd0cd3c1be97f7deb5283fa00048718482de4 (patch)
tree00169eb129b4ca13ceeb4879c4c5b7fb69c3c4fd /app-text/paperwork
parente0fac29676c44b996e61c06f8d5c92288e46966b (diff)
gentoo auto-resync : 07:11:2023 - 16:19:32
Diffstat (limited to 'app-text/paperwork')
-rw-r--r--app-text/paperwork/Manifest3
-rw-r--r--app-text/paperwork/paperwork-2.2.1.ebuild65
2 files changed, 68 insertions, 0 deletions
diff --git a/app-text/paperwork/Manifest b/app-text/paperwork/Manifest
index 16724661c222..6282dcfd084f 100644
--- a/app-text/paperwork/Manifest
+++ b/app-text/paperwork/Manifest
@@ -1,3 +1,6 @@
DIST paperwork-2.1.2.tar.gz 5907738 BLAKE2B 9b376e5ed13d69f0664c98d43a41cf876d21d46c31129b50c5c44e6d4279b04d302e7527906dad49b4416f698dfe9f5bafbc5130f41463efb5ca49fed0da308f SHA512 0f75fba66a0b9ed1b4b28caf9dbbcc4a0b7e68fa24f5faa40251c3f39c610be372f89a2f4e2e6807babd930bfeb45cc82216761f0da042deac991d779fdfdfbb
+DIST paperwork-2.2.1.tar.bz2 2529505 BLAKE2B e5545d3fbb5e41d0ddd21a0358fae496d127b30a3f72e1438eef679c520a3152e4db006d9dc42023431907281452931e90aea187c4928309bde7add2d54b5844 SHA512 f96ddf3efe3b5021e612600fa2e3a9c83db7ec78b9637e434facefcc422700be1b67b74231b4738a7762905ac5267f412839ff9d43cb9dcf7f95a5f3d6f7091f
+DIST paperwork-data-2.2.1.tar.gz 5210355 BLAKE2B 48ee8f9828f7aed9b41c998c2cdc43a2b98c2a2482e388500b8d04867a450bbf3264ef5a87d7f215f1389943e4cbab452d3a7a6235d63cfdb27127ab56ad9c2f SHA512 cf663368f733f45dde8242c3ad9ba405361628bddb7e8aed9dffeb5bb86c1abac7a3485cb7e2042d65006f8f336390fa81ea182dad62f4259b79805ac7a0416b
EBUILD paperwork-2.1.2.ebuild 1502 BLAKE2B 605398ebbd5a63ca9434d25f70207dbdfffbd9413f373dda6aba4e66b7018150ee22393a52169b8f2e193aaef557c3f931f596b11d4ccef3dadd647fa8e93ce7 SHA512 141455b2b92b89f33c43ffe9dbcf1cba27a89feb2aca4bc36ddcf8a3d488412f3c4378d4ceeb4adac865d99cce30876c231b67b77d55920e7ce80723df306d2c
+EBUILD paperwork-2.2.1.ebuild 1923 BLAKE2B 9b1830aba81acbc81abde5c38918bbc54c3432f04faff604264b98ed6ccb359191a23c813cc7efcdb9a916d54db85267bbc3fd7e2c9131dd159b982007567c3a SHA512 4885399743e7e1f9f43845e6a8cfbb702edf6758383a6b17c5d44c44fc577b06b231a4c36ee33eac1a31facee68fc328297150f8e84021201b61928b732c46aa
MISC metadata.xml 795 BLAKE2B eaa7ea613cab3ed3e9d3a009b5fba74f1424ae26d68321ab6e2942a16ccf154e5ff8db1559e7ab97864b7b979b97215a553bf2be97a0d0049feae4156ef66803 SHA512 2fd9d23d6b951b3d993b4acc6a6107ed907cd2cad4bfe88b40e72eaf9bc69d85c60a3192628658db9d2dc7dc2bf94d61b09816b7343bf8f2d72ee310b66dcc12
diff --git a/app-text/paperwork/paperwork-2.2.1.ebuild b/app-text/paperwork/paperwork-2.2.1.ebuild
new file mode 100644
index 000000000000..a5fa423d906a
--- /dev/null
+++ b/app-text/paperwork/paperwork-2.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="a personal document manager for scanned documents (and PDFs)"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+# Update from release hash at:
+# https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/tags
+REL_HASH="0bea4054"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/archive/${PV}/paperwork-${PV}.tar.bz2
+ https://download.openpaper.work/data/paperwork/master_${REL_HASH}/data.tar.gz -> paperwork-data-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="~app-text/openpaperwork-core-${PV}[${PYTHON_USEDEP}]
+ ~app-text/openpaperwork-gtk-${PV}[${PYTHON_USEDEP}]
+ ~app-text/paperwork-backend-${PV}[${PYTHON_USEDEP}]
+ dev-python/libpillowfight[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/pyocr-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyxdg-0.25[${PYTHON_USEDEP}]
+ media-libs/libinsane
+ x11-libs/libnotify[introspection]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ sys-devel/gettext"
+
+S=${WORKDIR}/paperwork-${PV}/${PN}-gtk
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ default
+ cp -a "${WORKDIR}"/${PN}-gtk ${WORKDIR}/paperwork-${PV}/
+}
+
+python_compile() {
+ emake l10n_compile
+
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # This queries tesseract languages and will fail sandbox with
+ # USE=opencl, bugs #793446 #830012 #852134
+ addpredict /dev/dri/renderD128
+ addpredict /dev/kfd
+ addpredict /dev/nvidiactl
+
+ PYTHONPATH="src" "${EPYTHON}" src/paperwork_gtk/main.py install \
+ --icon_base_dir="${ED}"/usr/share/icons \
+ --data_base_dir="${ED}"/usr/share
+}