summaryrefslogtreecommitdiff
path: root/app-text/passivetex/passivetex-1.25-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /app-text/passivetex/passivetex-1.25-r1.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'app-text/passivetex/passivetex-1.25-r1.ebuild')
-rw-r--r--app-text/passivetex/passivetex-1.25-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/passivetex/passivetex-1.25-r1.ebuild b/app-text/passivetex/passivetex-1.25-r1.ebuild
new file mode 100644
index 000000000000..d0aa4bc6536e
--- /dev/null
+++ b/app-text/passivetex/passivetex-1.25-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit latex-package
+
+DESCRIPTION="A namespace-aware XML parser written in Tex"
+HOMEPAGE="http://www.tei-c.org.uk/Software/passivetex/"
+# Taken from: http://www.tei-c.org.uk/Software/passivetex/${PN}.zip
+SRC_URI="mirror://gentoo/${P}.zip"
+S=${WORKDIR}/${PN}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ >=dev-tex/xmltex-1.9"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+ insinto ${TEXMF}/tex/xmltex/passivetex
+ doins *.sty *.xmt
+
+ dodoc README.passivetex index.{html,xml}
+}