summaryrefslogtreecommitdiff
path: root/app-text/pinfo/pinfo-99999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /app-text/pinfo/pinfo-99999.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'app-text/pinfo/pinfo-99999.ebuild')
-rw-r--r--app-text/pinfo/pinfo-99999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/pinfo/pinfo-99999.ebuild b/app-text/pinfo/pinfo-99999.ebuild
new file mode 100644
index 000000000000..961b78a24b48
--- /dev/null
+++ b/app-text/pinfo/pinfo-99999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic git-r3
+
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+HOMEPAGE="https://github.com/baszoetekouw/pinfo"
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls readline"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ nls? ( virtual/libintl )
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+ sys-devel/bison
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.9-GROFF_NO_SGR.patch
+ "${FILESDIR}"/${PN}-0.6.9-lzma-xz.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -D_BSD_SOURCE -D_DEFAULT_SOURCE # sbrk()
+
+ econf \
+ $(use_with readline) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" sysconfdir="${EPREFIX}/etc" install
+}