summaryrefslogtreecommitdiff
path: root/app-text/poppler/poppler-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
commit1494784ae35c6fa7b6a92a80dea93265fc54ccd0 (patch)
treedbbb1b83e130750c3a55a4287c3a2ec2bbff7af8 /app-text/poppler/poppler-9999.ebuild
parentee74b33422f15493c315bdacf20da95d5b936d3c (diff)
gentoo auto-resync : 18:06:2023 - 19:48:47
Diffstat (limited to 'app-text/poppler/poppler-9999.ebuild')
-rw-r--r--app-text/poppler/poppler-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 7a590da3c152..51de39add3e1 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -18,14 +18,14 @@ else
SRC_URI+=" test? ( https://gitlab.freedesktop.org/poppler/test/-/archive/${TEST_COMMIT}/test-${TEST_COMMIT}.tar.bz2 -> ${PN}-test-${TEST_COMMIT}.tar.bz2 )"
SRC_URI+=" verify-sig? ( https://poppler.freedesktop.org/${P}.tar.xz.sig )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
- SLOT="0/128" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+ SLOT="0/129" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
fi
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
HOMEPAGE="https://poppler.freedesktop.org/"
LICENSE="GPL-2"
-IUSE="boost cairo cjk curl +cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 test tiff +utils"
+IUSE="boost cairo cjk curl +cxx debug doc gpgme +introspection +jpeg +jpeg2k +lcms nss png qt5 test tiff +utils"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -38,6 +38,7 @@ COMMON_DEPEND="
introspection? ( >=dev-libs/gobject-introspection-1.64:= )
)
curl? ( net-misc/curl )
+ gpgme? ( >=app-crypt/gpgme-1.19.0:=[cxx] )
jpeg? ( >=media-libs/libjpeg-turbo-1.1.0:= )
jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
lcms? ( media-libs/lcms:2 )
@@ -120,6 +121,7 @@ src_configure() {
-DWITH_Cairo=$(usex cairo)
-DENABLE_LIBCURL=$(usex curl)
-DENABLE_CPP=$(usex cxx)
+ -DWITH_Gpgmepp=$(usex gpgme)
-DWITH_JPEG=$(usex jpeg)
-DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
-DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)