summaryrefslogtreecommitdiff
path: root/app-text/rman/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/rman/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/rman/files')
-rw-r--r--app-text/rman/files/rman-3.2-format-security.patch16
-rw-r--r--app-text/rman/files/rman-3.2-gentoo.diff19
-rw-r--r--app-text/rman/files/rman-3.2-ldflags.patch13
3 files changed, 48 insertions, 0 deletions
diff --git a/app-text/rman/files/rman-3.2-format-security.patch b/app-text/rman/files/rman-3.2-format-security.patch
new file mode 100644
index 000000000000..77070026bdb9
--- /dev/null
+++ b/app-text/rman/files/rman-3.2-format-security.patch
@@ -0,0 +1,16 @@
+ rman.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/rman.c b/rman.c
+index d09e547..e5fc88d 100644
+--- a/rman.c
++++ b/rman.c
+@@ -1372,7 +1372,7 @@ HTML(enum command cmd) {
+ break;
+ case BEGINSECTION: break;
+ case ENDSECTION:
+- if (sectheadid==NAME && message!=NULL) printf(message);
++ if (sectheadid==NAME && message!=NULL) printf("%s", message);
+ break;
+ case BEGINSUBSECTION: break;
+ case ENDSUBSECTION: break;
diff --git a/app-text/rman/files/rman-3.2-gentoo.diff b/app-text/rman/files/rman-3.2-gentoo.diff
new file mode 100644
index 000000000000..ece1e3807e66
--- /dev/null
+++ b/app-text/rman/files/rman-3.2-gentoo.diff
@@ -0,0 +1,19 @@
+diff -urN rman-3.2.orig/Makefile rman-3.2/Makefile
+--- rman-3.2.orig/Makefile 2003-07-26 12:15:00.000000000 -0700
++++ rman-3.2/Makefile 2005-07-12 01:01:37.000000000 -0700
+@@ -15,13 +15,8 @@
+ # this must be a directory that's in your bin PATH.
+ # MANDIR holds the man page.
+
+-BINDIR = /opt/local/bin
+-#BINDIR = /usr/local/bin
+-#BINDIR = //C/bin
+-MANDIR = /usr/local/man/man1
+-# popular alternative
+-#BINDIR = /opt/local/bin
+-#MANDIR = /opt/local/man/man1
++BINDIR = /usr/bin
++MANDIR = /usr/share/man/man1
+
+
+ ### if you have GNU gcc, use these definitions
diff --git a/app-text/rman/files/rman-3.2-ldflags.patch b/app-text/rman/files/rman-3.2-ldflags.patch
new file mode 100644
index 000000000000..4a6f5f5d9eab
--- /dev/null
+++ b/app-text/rman/files/rman-3.2-ldflags.patch
@@ -0,0 +1,13 @@
+Index: rman-3.2/Makefile
+===================================================================
+--- rman-3.2.orig/Makefile
++++ rman-3.2/Makefile
+@@ -102,7 +102,7 @@ all: rman
+
+ # everyone but me zaps assertions with the -DNDEBUG flag
+ rman: rman.c Makefile
+- $(CC) -DNDEBUG $(defs) -DPOLYGLOTMANVERSION=\"$(version)\" $(CFLAGS) -o rman rman.c
++ $(CC) $(LDFLAGS) -DNDEBUG $(defs) -DPOLYGLOTMANVERSION=\"$(version)\" $(CFLAGS) -o rman rman.c
+
+
+ debug: