summaryrefslogtreecommitdiff
path: root/app-text/rnc2rng/rnc2rng-2.6.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /app-text/rnc2rng/rnc2rng-2.6.6-r1.ebuild
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'app-text/rnc2rng/rnc2rng-2.6.6-r1.ebuild')
-rw-r--r--app-text/rnc2rng/rnc2rng-2.6.6-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/rnc2rng/rnc2rng-2.6.6-r1.ebuild b/app-text/rnc2rng/rnc2rng-2.6.6-r1.ebuild
new file mode 100644
index 000000000000..2c7a835ba983
--- /dev/null
+++ b/app-text/rnc2rng/rnc2rng-2.6.6-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="RELAX NG Compact to regular syntax conversion library"
+HOMEPAGE="https://github.com/djc/rnc2rng"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/rply[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${PYTHON}" test.py
+}