summaryrefslogtreecommitdiff
path: root/app-text/ronn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /app-text/ronn
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'app-text/ronn')
-rw-r--r--app-text/ronn/Manifest1
-rw-r--r--app-text/ronn/ronn-0.7.3-r4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-text/ronn/Manifest b/app-text/ronn/Manifest
index 66f495588bb0..cfe1a09dc0c5 100644
--- a/app-text/ronn/Manifest
+++ b/app-text/ronn/Manifest
@@ -1,3 +1,4 @@
DIST ronn-0.7.3.gem 61440 BLAKE2B 3ff0a1752d7a972b7d8319cac2b1287e7d21207e22b9eb288694172eb9b30b2198e4378eb02df8418585a44d3d2c89b4695675933dc5ef5d9ba63c78e71f4e7c SHA512 885418c88d5a1073f9457ea11e29d82d3bb40ad12506589ccfab83ad447445e41282c9688aba5646082ae5ecc6a047fa9439ffae14561152fc61a136474f611c
EBUILD ronn-0.7.3-r3.ebuild 1163 BLAKE2B 69f0e58f11eeac58714bcef08c6e62ec182ebdd68c21e0b589db88eee8209a696f6d62da1ff1a6a78c08ecdcfad892966af16dcd53fb77d4ecbfc2a756706ce4 SHA512 6714f18e70c27e9a67a6dfab82a34d9505f5b975204f57ef0bf9c843872fc18429a592d8d762fde9877145977fc5669d67cd4da009a6fc8364b9e755a607409d
+EBUILD ronn-0.7.3-r4.ebuild 1162 BLAKE2B 00ff26318e4644f3eb0cb90939820c0dfe6af8e7e1772ceee6ac4c50f398d8087ef413982249d4aba39fc970ff7ed0fafc2f92660921746b0bcf630a234f4faf SHA512 aac2be29211f89280a53690e0d27fd56103db2b097beac2b07d41ee7b390d97b78bd89f2c4910992b8ad3b722ad02fe9e720815577fbd3f22db366c87ddeb153
MISC metadata.xml 339 BLAKE2B 2a1722a0531a1ccaba0d29a1ace114b95789ba4b0c692e8efcf38605f81de4dd1210671331fcdb5baa6536cf38fbf63f11b85fb13bd6a067be56f22a372fc5b6 SHA512 0be4072cf3514eba60569138ed409362b318616ad4514e319d9b4add120e74fd7655e2fc5c3ab8d7b5d813cfcf8e1054fb98395a1a89d9fb90e447a825ee9439
diff --git a/app-text/ronn/ronn-0.7.3-r4.ebuild b/app-text/ronn/ronn-0.7.3-r4.ebuild
new file mode 100644
index 000000000000..ae854cc60751
--- /dev/null
+++ b/app-text/ronn/ronn-0.7.3-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Converts simple, human readable textfiles to roff for terminal display, and HTML"
+HOMEPAGE="https://github.com/rtomayko/ronn/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+IUSE=""
+
+DEPS="
+ >=dev-ruby/hpricot-0.8.2
+ >=dev-ruby/mustache-0.7.0
+ >=dev-ruby/rdiscount-1.5.8"
+
+ruby_add_rdepend "${DEPS}"
+
+ruby_add_bdepend "${DEPS}"
+
+all_ruby_prepare() {
+ # Avoid test failing due to changes in hash handling in ruby 1.8.7:
+ # https://github.com/rtomayko/ronn/issues/56
+ sed -i -e '81 s:^:#:' test/test_ronn.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}